WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 20 months ago

Last modified 20 months ago

#12532 closed defect (bug) (duplicate)

Image Upload Does Not Display Errors

Reported by: drgdc Owned by:
Milestone: Priority: normal
Severity: normal Version: 2.9.2
Component: Upload Keywords:
Focuses: Cc:

Description

This has been a long standing problem for me. I am having problems with uploaded images and am unable to properly troubleshoot because the image upload feature does not display errors.

The root problem is that the image upload feature does not display error messages. The symptoms are that thumbnail images are not being generated and my theme (AutoFocus) cannot display EXIF data for images. I have switched to the default theme, disabled plugins and performed other troubleshooting activities (http://wordpress.org/support/topic/164999?replies=1).

Scenario: I am uploading a 800x600 143KB color JPEG image. The Flash upload tool shows the status bar going to 100%, Crunching... and then stops once the bar clears itself and the "Save all changes button" appears. Nothing else happens. No image thumbnail is displayed, no image information (titles and descriptions) is displayed.

When I close out the 'Add an Image' window and reopen it I can see the image in the Gallery but there are no resized images available (thumbnail, medium, large) and the full size dimension is listed as 0x0. When I choose to Edit Image I get the error "Image data does not exist. Please re-upload the image."

I repeat the upload process using the browser upload method. Once the image is uploaded the 'Add an Image' window is cleared and is left blank. Closing the window and going into the Gallery yields the same results as the Flash method above.

WordPress 2.9.2

General

  • OS: Linux
  • Server: Apache/2.2.3 (Red Hat)
  • Hostname: blog.radian.net
  • IP:Port: 76.12.173.65:80
  • Document Root: /vservers/h77483wp/htdocs

PHP

  • v5.1.6
  • GD: bundled (2.0.28 compatible)
  • Magic Quotes GPC: Off
  • Memory Limit: 16.0 MiB
  • Max Upload Size: 30.0 MiB

MYSQL

  • v5.0.77
  • Maximum No. Connections: 100
  • Maximum Packet Size: 1,024.0 KiB
  • Data Disk Usage: 3.8 MiB
  • Index Disk Usage: 283.0 KiB

I will attach a ZIP file with the image in question (other images have the same problem) as well as images of the upload windows and WP administration panels.

Attachments (7)

Browser Upload.png (59.1 KB) - added by drgdc 5 years ago.
Flash Upload.png (69.8 KB) - added by drgdc 5 years ago.
Media Settings.png (50.3 KB) - added by drgdc 5 years ago.
Miscellaneous Settings.png (46.9 KB) - added by drgdc 5 years ago.
Server Info.png (50.3 KB) - added by drgdc 5 years ago.
View Gallery.png (129.0 KB) - added by drgdc 5 years ago.
View Gallery Error.png (85.0 KB) - added by drgdc 5 years ago.

Download all attachments as: .zip

Change History (14)

@drgdc5 years ago

@drgdc5 years ago

@drgdc5 years ago

@drgdc5 years ago

@drgdc5 years ago

@drgdc5 years ago

comment:1 @drgdc5 years ago

The attachment size limit will not allow me to attach the image. You can find it at http://204.12.19.79/Sandcastle.jpg

comment:3 @nacin5 years ago

  • Milestone changed from Unassigned to 3.1

comment:4 @nacin4 years ago

  • Keywords needs-patch reporter-feedback added; image upload error removed
  • Milestone changed from Awaiting Triage to Future Release

comment:5 @iseulde20 months ago

  • Keywords needs-patch reporter-feedback removed
  • Resolution set to invalid
  • Status changed from new to closed

Media has been redone in 3.5.

comment:6 @sabreuse20 months ago

  • Milestone Future Release deleted

comment:7 @helen20 months ago

  • Resolution changed from invalid to duplicate

Duplicate of #23127.

Note: See TracTickets for help on using tickets.