Make WordPress Core

Opened 6 years ago

Closed 6 years ago

#12550 closed defect (bug) (duplicate)

wp_nonce_field() passes unnecessary argument

Reported by: TobiasBg Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: General Keywords:
Focuses: Cc:


wp_nonce_field() passes a second argument (with the value 'previous') to the function wp_referer_field(). However, that function only expects one parameter, so the second one is obsolete and should be removed.

Attached patch removes the unnecessary argument. It is the only occurance (of two total) in core where wp_referer_field() gets passed two parameters.

Attachments (1)

12550.patch (718 bytes) - added by TobiasBg 6 years ago.
Patch removes extra argument from function call

Download all attachments as: .zip

Change History (3)

6 years ago

Patch removes extra argument from function call

#1 @nacin
6 years ago

See also #10057.

#2 @TobiasBg
6 years ago

  • Keywords has-patch commit removed
  • Milestone 3.0 deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Thanks nacin. Hadn't seen the other ticket... My bad.

Closing this as a duplicate of #10057 then, as basically the same patch is also in the other ticket.

That ticket should however be addressed then, to not keep pushing it again.

Note: See TracTickets for help on using tickets.