WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#12562 closed enhancement (fixed)

Default should be to NOT page comments

Reported by: joostdevalk Owned by: joostdevalk
Milestone: 3.0 Priority: normal
Severity: normal Version: 3.0
Component: Comments Keywords: has-patch dev-feedback
Focuses: Cc:

Description

It makes no sense to enable paged comments by default, as most people won't need it and a lot of people will not know what it is the first time they encounter it.

Attachments (1)

page_comments.diff (3.0 KB) - added by joostdevalk 4 years ago.
Patch

Download all attachments as: .zip

Change History (11)

joostdevalk4 years ago

Patch

comment:1 joostdevalk4 years ago

  • Keywords has-patch dev-feedback added; haspatch removed

comment:2 follow-up: Denis-de-Bernardy4 years ago

additional reasons:

  • it's completely broken, in the way it orders things (or fails to do such)
  • it breaks comment permalinks, in that it no longer is possible to link to one particular comment

comment:3 jane4 years ago

I'm in favor of comment paging being off by default (comment threading being on). It's an aggravating UI to see there be one or two comments on a post's page, with a link to older comments. For the average user, the number of comments doesn't really require paging, so it should be an option, not a default.

comment:4 nacin4 years ago

  • Resolution set to fixed
  • Status changed from new to closed

(In [13636]) Don't page comments by default. fixes #12562

comment:5 in reply to: ↑ 2 Viper007Bond4 years ago

Replying to Denis-de-Bernardy:

  • it's completely broken, in the way it orders things (or fails to do such)

Some actual details would be helpful as I am unable to reproduce.

  • it breaks comment permalinks, in that it no longer is possible to link to one particular comment

Sorry, but this is incorrect. A comment will always be on the same page number unless older comments are deleted/approved.

When commenting on Trac tickets, it'd be a lot more helpful if you described the issue rather than just saying "it's broken" or "it breaks stuff" without providing any details.

comment:6 follow-up: nacin4 years ago

Just for the record, I committed this for the UX reasons brought up by joostdevalk and furthered by jane. "It's completely broken" and "It breaks" played no part in that decision.

comment:7 in reply to: ↑ 6 ; follow-up: Viper007Bond4 years ago

Replying to nacin:

Just for the record, I committed this for the UX reasons brought up by joostdevalk and furthered by jane. "It's completely broken" and "It breaks" played no part in that decision.

Yeah, don't worry, I agree with the default change. I'm merely trying to figure out what in the heck Denis is talking about. :)

comment:8 in reply to: ↑ 7 ; follow-up: Denis-de-Bernardy4 years ago

Replying to Viper007Bond:

Replying to nacin:

Just for the record, I committed this for the UX reasons brought up by joostdevalk and furthered by jane. "It's completely broken" and "It breaks" played no part in that decision.

Yeah, don't worry, I agree with the default change. I'm merely trying to figure out what in the heck Denis is talking about. :)

I take it you've never played with the "Comments should be displayed with the (oldest|newest) comments at the top of each page". :-)

Imo, we should:

  1. drop this option entirely
  2. order comments by date DESC on the post's page (i.e. the most recent comments)
  3. order comments by date ASC on comment pages (i.e. to keep permalinks)

comment:9 in reply to: ↑ 8 ; follow-up: Viper007Bond4 years ago

Replying to Denis-de-Bernardy:

I take it you've never played with the "Comments should be displayed with the (oldest|newest) comments at the top of each page". :-)

If I'm remembering correctly I wrote that code, so yes, I have played with it. :)

Imo, we should:

  1. drop this option entirely
  2. order comments by date DESC on the post's page (i.e. the most recent comments)
  3. order comments by date ASC on comment pages (i.e. to keep permalinks)
  1. I think you're significantly underestimating the number of users who like their newest comments on top. It's not the majority, but we'd piss off a ton of users if it was removed. I added this feature because it was supported in the old plugin that added the paged comments feature and because I had seen multiple blogs using the option.
  1. This is controlled by the what-page-to-display-by-default option -- either the latest page or the oldest page. User preference trumps your preference. ;)
  1. You are mistaken. Page number 1 is ALWAYS the oldest comments, regardless of settings. As I mentioned above, adding new comments or changing any of the settings in the admin area will not change the comment's permalink.

comment:10 in reply to: ↑ 9 Viper007Bond4 years ago

Replying to Viper007Bond:

  1. You are mistaken. Page number 1 is ALWAYS the oldest comments, regardless of settings. As I mentioned above, adding new comments or changing any of the settings in the admin area will not change the comment's permalink.

The comment ordering (newest or oldest on top) is only per-page.

Note: See TracTickets for help on using tickets.