WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 4 years ago

#12577 closed defect (bug) (duplicate)

Wrong thumbnails created - transparency

Reported by: pavelevap Owned by: apeatling
Milestone: Priority: normal
Severity: normal Version: 2.9.2
Component: Media Keywords:
Focuses: Cc:

Description

When I upload attached .png picture, wrong thumbnails are created (black and white lines etc.) It is probably related to transparency...

Attachments (1)

Kampa.png (30.7 KB) - added by pavelevap 5 years ago.

Download all attachments as: .zip

Change History (12)

@pavelevap5 years ago

comment:1 @dd325 years ago

  • Milestone changed from 2.9.3 to 3.0

See Also: http://www.php.net/manual/en/function.imagecopyresampled.php#93166

basically, the GD resize functions do not handle transparency.

Setting to 3.0 at present, This is unlikely to be patched for a 2.9 release.

comment:2 @apeatling5 years ago

  • Owner set to apeatling
  • Status changed from new to assigned

comment:3 @apeatling5 years ago

I'm almost certain that this is because all thumbnails are created as JPG's regardless of their original file type, but I'll start digging to confirm.

comment:4 @apeatling5 years ago

I take that back, my png tests seemed to thumbnail fine, but I could reproduce the issue with the attached image.

comment:5 @nacin5 years ago

Related? #11671

comment:6 @apeatling5 years ago

@nacin - Yes, seems to be the same problem, it's to do with the color profile of the image.

It's using a "20% Dot Gain" profile. If I open the image in Photoshop and remove the profile then the thumbnail works fine.

comment:7 @apeatling5 years ago

  • Cc apeatling added

comment:8 @apeatling5 years ago

Punt to 3.1? This should be fixed once #11671 is dealt with.

comment:9 @nacin5 years ago

  • Milestone changed from 3.0 to 3.1

comment:10 @scribu4 years ago

  • Milestone changed from Awaiting Triage to Future Release

comment:11 @scribu4 years ago

  • Milestone Future Release deleted
  • Resolution set to duplicate
  • Status changed from assigned to closed

Actually, I'm just going to mark this as a dup of #11671

Note: See TracTickets for help on using tickets.