WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#12592 closed defect (bug) (invalid)

buddypress and gravatar conflict using P2, WPMU

Reported by: azizpoonawalla Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: General Keywords:
Focuses: Cc:

Description

Theme: P2 v1.0.4
WPMU v2.9.2

when i activate the Buddypress plugin, gravatars for replies to a post inherit the same gravatar as the original post author.

If the comment is made by a registered user, the gravatar loads correctly. Comments left by unregistered users however do not show the correct gravatar, even though email address is correctly entered.

Tested using Buddypress v1.2.1 and 1.2.2 - same error.

Change History (3)

comment:1 scribu4 years ago

  • Milestone Unassigned deleted
  • Resolution set to invalid
  • Status changed from new to closed

This trac is for WordPress. You should report this bug here, instead:

http://trac.buddypress.org/

comment:2 azizpoonawalla4 years ago

OK will post the ticket there. The issue however does not seem to be replicable using other themes than P2 (which is an official Wordpress theme) and only occurs on Wordpress MU and not single-install wordpress. So there's at least some justification for thinking the problem is not solely limited to the Buddypress plugin. Hopefully they wont point the finger straight back here :P

comment:3 dd324 years ago

  • Keywords P2 gravatar buddypress WPMU removed
  • Version 2.9.2 deleted

themes than P2 (which is an official Wordpress theme)

The only "official wordpress theme"'s are WordPress Classic, WordPress Default, and TwentyTen. All other themes are considered 3rd party, regardless of who is the maintainer of it.

Automattic is the "owner"/creator of the P2 theme, and any bugs should be reported to them or you may get support in the WordPress.org support forums.

Note: See TracTickets for help on using tickets.