WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#12599 closed defect (bug) (duplicate)

Media/Miscellaneous Settings And Possible Clean-Up

Reported by: markmcwilliams Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.0
Component: Administration Keywords:
Focuses: Cc:

Description

I just uploaded a fresh 3.0-ALPHA install, and in going about setting up everything that needs setup, I found a couple of things I don't think are quite right?

Makes sense for the 'Uploading Files' to move to /wp-admin/options-media.php from /wp-admin/options-misc.php however I think a little bit of code forgot to be taken with it! :(

Shouldn't [] Track links’ update times be in /wp-admin/options-media.php if it's actually really needed IMO, what exactly is it used for? - That'd therefor mean /wp-admin/options-misc.php could really be removed, or rather hidden as I remember reading somewhere that plugins may use it?

Another thing, couldn't we move the Privacy Settings over to /wp-admin/options-general.php, or at least another page, yet I feel that more appropriate. It'd sure give the Settings Menu a little clean-up for sure! :)

Couldn't find any related tickets, so thoughts are welcome, I'm not sure what Jane thinks with regards to UI, but I'd +1 it anyway!

Change History (3)

comment:1 ocean904 years ago

Releated #12437

comment:2 nacin4 years ago

  • Milestone 3.0 deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Lowering the profile of the privacy options panel seems like an instant wontfix. Everything else is a duplicate of #12437, which I imagine is where you remember reading that plugins might use it. (Or #11687, where this started.)

comment:3 markmcwilliams4 years ago

All I'm going to say is that Trac Search must have a problem, it didn't bring that ticket up in my search, the reason I opened this one! ;)

Note: See TracTickets for help on using tickets.