WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 4 years ago

#12627 closed defect (bug) (worksforme)

Orphaned Comments Missing in edit-comments.php

Reported by: miqrogroove Owned by:
Milestone: Priority: normal
Severity: normal Version: 2.9.2
Component: Comments Keywords: close
Focuses: Cc:

Description

If the comments table contains rows that do not relate to the posts table, the comments rows are counted in the stats and paging, but the comments themselves are not displayed on the Comments screen. This would be akin to unattached media magically disappearing from the Media Library.

Change History (4)

comment:1 scribu4 years ago

  • Keywords close added

Unlike comments, images are hard-coded in the post content. That's why it makes sense to display unatached media.

Displaying orphaned comments is plugin territory.

comment:2 scribu4 years ago

What I'm trying to say is that an orphaned comment is caused by a database inconsistency, whereas a media item can be created without a parent post.

comment:3 scribu4 years ago

A (core) plugin could be written to check for all kinds of inconsitencies: orphaned comments, invalid author ids, messed up taxonomy tables etc.

comment:4 nacin4 years ago

  • Milestone 3.0 deleted
  • Resolution set to worksforme
  • Status changed from new to closed

These should always be in sync.

Note: See TracTickets for help on using tickets.