WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 5 years ago

#12638 closed defect (bug) (fixed)

Indent Button Broken

Reported by: miqrogroove Owned by: azaozz
Milestone: 3.1 Priority: normal
Severity: normal Version: 2.9.2
Component: TinyMCE Keywords:
Focuses: Cc:

Description

Steps to Reproduce:

  1. Add a new post.
  1. Type something in the content area.
  1. Highlight it.
  1. Click the Ordered List button.
  1. Click it again.
  1. Click the Indent button.

Actual Result:

Nothing happens at step 6.

Expected Result:

Text should be indented.

Reproducibility:

Always in Firefox and Chrome. WP branch and trunk. IE seems to work.

Change History (5)

comment:1 @dd325 years ago

Confirmed in Firefox.

Works fine under Opera.

Appears to be buggy under Firefox 3.6 on http://tinymce.moxiecode.com/examples/full.php - First paragraph it works fine on, Attempt to use it on the 2nd paragraph and it'll indent the first paragraph.

comment:2 @ocean905 years ago

  • Keywords needs-patch added

Maybe we should report that on TinyMCE bug tracker too. There a some bugs related to indent.
Wontfix and that TinyMCE will fix it in future?

comment:3 @azaozz5 years ago

  • Milestone changed from 3.0 to 3.1

It seems to be working properly in TinyMCE's 3.3 branch http://tinymce.moxiecode.com/examples/full.php. Unfortunately it came out too late for inclusion in WordPress 3.0 so this will be fixed in 3.1.

comment:4 @nacin5 years ago

  • Milestone changed from Awaiting Triage to 3.1

Updating TinyMCE should resolve a lot of bugs we're seeing in various browsers.

comment:5 @ocean905 years ago

  • Keywords needs-patch removed
  • Resolution set to fixed
  • Status changed from new to closed

Fixed with [15683]. (#12574)

(Tested with Chrome, FF and IE)

Note: See TracTickets for help on using tickets.