Make WordPress Core

Opened 14 years ago

Closed 14 years ago

#12642 closed defect (bug) (fixed)

Renaming of get_usernumposts() breaks some plugins/themes

Reported by: viper007bond's profile Viper007Bond Owned by:
Milestone: 3.0 Priority: normal
Severity: normal Version: 3.0
Component: General Keywords: has-patch
Focuses: Cc:


r13576 renamed get_usernumposts(). This has the potential to break plugins/themes (already got one report on IRC).

Is it really a wise to fully get rid of a function that's been around since 0.71?

Attached patch reintroduces the function in deprecated form.

Attachments (1)

12642.patch (1.3 KB) - added by Viper007Bond 14 years ago.

Download all attachments as: .zip

Change History (2)

14 years ago

#1 @nacin
14 years ago

  • Resolution set to fixed
  • Status changed from new to closed

(In [13761]) Restore accidental removal of get_usernumposts(). This function is now deprecated in favor of count_user_posts() for naming consistency. fixes #12642 props Viper007Bond.

Note: See TracTickets for help on using tickets.