WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 4 years ago

#12649 closed defect (bug) (duplicate)

Warning: strpos() expects... in rss.php

Reported by: lordgun Owned by: dd32
Milestone: Priority: normal
Severity: normal Version: 2.9.2
Component: HTTP API Keywords: warning php
Focuses: Cc:

Description

Some RSS are generating Warning because headers are treated as strings and Twitter for example is sometimes using int types.

Attachments (2)

ScreenShot001.jpg (18.0 KB) - added by lordgun 4 years ago.
wp-12649.patch (617 bytes) - added by lordgun 4 years ago.

Download all attachments as: .zip

Change History (6)

lordgun4 years ago

comment:1 nacin4 years ago

MagpieRSS is deprecated. Use Simplepie instead.

lordgun4 years ago

comment:2 nacin4 years ago

  • Component changed from Warnings/Notices to HTTP
  • Owner changed from westi to dd32

comment:3 nacin4 years ago

  • Status changed from new to assigned

comment:4 dd324 years ago

  • Resolution set to duplicate
  • Status changed from assigned to closed

This ticket is a duplicate of #12045, All Headers returned should be Strings, however, the WP_HTTP class may return an array for multiple headers present. This commit fixed the snoopy compat layer to return it in the style expected.

(In [13848]) Fix WP_HTTP -> Snoopy Compat layer for Magpie RSS. Fixes #12045

Note: See TracTickets for help on using tickets.