WordPress.org

Make WordPress Core

Opened 9 years ago

Closed 9 years ago

#12658 closed defect (bug) (worksforme)

Custom post type trash showing all posts of type

Reported by: jfarthing84 Owned by:
Milestone: Priority: high
Severity: critical Version: 3.0
Component: Posts, Post Types Keywords: dev-feedback
Focuses: Cc:

Description

The custom post type edit screen is showing ALL posts in a particular type within the trash for that type, even though they are NOT trash.

Change History (1)

#1 @dd32
9 years ago

  • Milestone Unassigned deleted
  • Resolution set to worksforme
  • Status changed from new to closed

I cant reproduce this.

Created a custom post_type, Created 3 items, Trashed one.

Visited wp-admin/edit.php?post_status=trash&post_type=wiki, Result was Trashed item visible, other 2 items not.

Can you try under the latest trunk release, with a new post_type? It could be, there was a bug in the trash feature at some point and thats affecting your install..

Closing as worksforme, if problem persists on a new install or a new post_type, re-open with more details for verifying it..

Note: See TracTickets for help on using tickets.