WordPress.org

Make WordPress Core

Opened 12 years ago

Closed 11 years ago

#12699 closed task (blessed) (fixed)

Custom Background screen needs to better adapt to translation

Reported by: xibe Owned by:
Milestone: 3.0 Priority: high
Severity: normal Version: 3.0
Component: UI Keywords:
Focuses: Cc:

Description

The option for the /wp-admin/themes.php?page=custom-background screen can get scrambled and pushed to create a newline in some case when translation needs more word than the English original. This can mess up the screen's UI.

See attached screenshot.

Attachments (2)

custom-background.png (9.3 KB) - added by xibe 12 years ago.
Less usable UI when fr_FR translation is applied.
fr.diff (1.2 KB) - added by meheranandk 11 years ago.

Download all attachments as: .zip

Change History (12)

@xibe
12 years ago

Less usable UI when fr_FR translation is applied.

@meheranandk
11 years ago

#1 @meheranandk
11 years ago

I personally couldn't reproduce the bug since I do not know French. I believe that this patch should fix the issue.

#3 @nacin
11 years ago

Main custom background ticket: #12186

#4 @johnonolan
11 years ago

  • Cc johnonolan added
  • Priority changed from normal to high
  • Type changed from defect (bug) to enhancement

Note on the above mockup - the "remove image" and "upload image" sections need to swap places per feedback from Jane, other than that it's ready for a patch.

#5 @jane
11 years ago

If the options for each column are vertical, but the columns themselves remain, it should work better with translated strings, as there will be more room.

#6 @PeteMall
11 years ago

  • Keywords needs-patch added

#7 @ocean90
11 years ago

  • Keywords needs-patch removed
  • Milestone 3.0 deleted
  • Resolution set to duplicate
  • Status changed from new to closed

See #12186.

#8 @nacin
11 years ago

  • Milestone set to 3.0
  • Type changed from enhancement to task (blessed)

Re-opening, my bad. This ticket will be used to implement the mockup. TECannon has a patch.

#9 @nacin
11 years ago

  • Resolution duplicate deleted
  • Status changed from closed to reopened

#10 @nacin
11 years ago

  • Resolution set to fixed
  • Status changed from reopened to closed

(In [14209]) Custom background UI tweaks. Props TECannon. see #12186, fixes #12699

Note: See TracTickets for help on using tickets.