WordPress.org

Make WordPress Core

Opened 10 years ago

Closed 10 years ago

#12701 closed defect (bug) (duplicate)

Favorite menu doesn't always allow for feminine/specific form

Reported by: xibe Owned by: nbachiyski
Milestone: Priority: normal
Severity: normal Version: 3.0
Component: I18N Keywords:
Focuses: Cc:
PR Number:

Description

The top item for the Favorite menu sometimes relies on the following string: "New %s", where %s can be any form post_type.

This does not work for some languages other than English. For instance in French, Article (Post) is masculine but requires "Nouvel" instead of the normal translation "Nouveau"; Page and Catégorie are feminine, and therefore require "Nouvelle".

Since there also exist proper translations for each media type, this can turn into screens that feature both the wrong generated string, followed by the correct translation. See attached screenshot for fr_FR when in /wp-admin/edit.php .
(the whole uppercase/lowercase issue is another thing altogether :) )

Guilty string is in wp-admin/includes/template.php at line 3325, in favorite_actions().

Attachments (1)

fav-menu.png (2.2 KB) - added by xibe 10 years ago.
Demonstration of difference when using fr_FR (two top strings).

Download all attachments as: .zip

Change History (4)

@xibe
10 years ago

Demonstration of difference when using fr_FR (two top strings).

#1 @demetris
10 years ago

It’s a problem in Greek too.

A similar issue exists with the titles of the edit.php and post.php screens. From a quick look, I think the only way to solve it will be to have register_post_type() also specify full strings, like “Edit Post” and “Edit Posts”, and not only the singular and plural of the post type name (“Post” and “Posts”).

#2 @nacin
10 years ago

  • Status changed from new to assigned

We can move this over to $post_type->add_new_label or something to that effect, which I imagine we'll add. assigning to Nikolay for now.

see also #12697.

#3 @nacin
10 years ago

  • Milestone 3.0 deleted
  • Resolution set to duplicate
  • Status changed from assigned to closed

Closing as a duplicate of #12968.

Note: See TracTickets for help on using tickets.