WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 19 months ago

#12714 closed defect (bug) (worksforme)

New Clean Install returns Internal Server Error

Reported by: azizur Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Upgrade/Install Keywords: reporter-feedback
Focuses: Cc:

Description

I just tried to do a clean install so I set-up my Apache virtual host and ready to go through the new install process.

At this point I was expecting to see WordPress install screen and asking me to create a wp-config.php file through a web interface.

But I was presented with a Internal Server Error right after the button to create configuration file and message saying: "You can create a wp-config.php file through a web interface, but this doesn't work for all server setups. The safest way is to manually create the file."

Listening to the advise given, I have manually created the wp-config.php and everything is working.

How to reproduce this problem it: I tested it under the following configuration:

OS: Windows 7
Browser: IE8 + Firefox
Zend Server CE PHP Version 5.3.1
Apache/2.2.14 (Win32) mod_ssl/2.2.14 OpenSSL/0.9.8k Server at wordpress-trunk Port 80

Not really sure of this is related to Ticket #11289. Or this just a issue with Zend Server CE. All my other sites working fine without any issue.

Attachments (1)

WordPress - Error_1269558290437.png (21.5 KB) - added by azizur 4 years ago.
WordPress Internal Server Error on New Install

Download all attachments as: .zip

Change History (6)

azizur4 years ago

WordPress Internal Server Error on New Install

comment:1 follow-up: dd324 years ago

Can you please check your error logs to see if one was recorded?

Can you reproduce it on a new install? (A 2nd one)

comment:2 dd324 years ago

  • Keywords reporter-feedback added

comment:3 in reply to: ↑ 1 azizur4 years ago

Replying to dd32:

Can you please check your error logs to see if one was recorded?

Can you reproduce it on a new install? (A 2nd one)

I have set up another two (one at work and one at home) also seems to suffer from the same issue.

one thing is clear is that when I create a wp-config.php or when I click "Create a Configuration File" it goes away.

In the log file I only see 404 for favicon.ico no php error or apache errors. I have also tried define('WP_DEBUG', true); and @ini_set('log_errors','On');
@ini_set('error_log','../logs/php_error.log'); in index.php nothing is recorded in logs.

comment:4 dd324 years ago

  • Milestone changed from 3.0 to Future Release

In the log file I only see 404 for favicon.ico no php error or apache errors. I have also tried define('WP_DEBUG', true); and @ini_set('log_errors','On'); @ini_set('error_log','../logs/php_error.log'); in index.php nothing is recorded in logs.

You'd probably have to add that to wp-load.php below the error_reporting calls

Without having access to the server directly, and unable to reproduce it locally, its a bit hard to test this one..

Moving to Future Release until its tracked down..

comment:5 SergeyBiryukov19 months ago

  • Component changed from General to Upgrade/Install
  • Milestone Future Release deleted
  • Resolution set to worksforme
  • Status changed from new to closed

No traction in 3 years. Feel free to reopen with more information if there's still a problem.

Note: See TracTickets for help on using tickets.