WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#12724 closed defect (bug) (wontfix)

twentyten theme single column width

Reported by: usermrpapa Owned by: iammattthomas
Milestone: Priority: normal
Severity: normal Version: 3.0
Component: Themes Keywords:
Focuses: Cc:

Description

is it just me? why if you select the one column, no sidebar page template on the new default theme, is the content area the same width as if there was a sidebar?

The styling: .onecolumn #content

is limiting the content width to 640px... So you end up with a relatively narrow content column with a large amount of whitespace (half sidebar width) on either side...

Why not make that .onecolumn #content styling width be 100% so the single column format actually uses the available width?

can't imagine this is intentional...

Change History (9)

comment:1 usermrpapa4 years ago

  • Cc steve@… added

comment:2 usermrpapa4 years ago

happy to work up a patch, but wanted to see if there was something else at play here...

comment:3 usermrpapa4 years ago

  • Owner set to iammattthomas
  • Status changed from new to assigned

comment:4 jane4 years ago

  • Priority changed from high to normal

comment:5 iammattthomas4 years ago

  • Resolution set to wontfix
  • Status changed from assigned to closed

This is by design. The theme's content width is designed to be a set 640 pixels wide for comfortable reading ("Choose a Comfortable Measure," The Elements of Typographic Style) and reliable image alignment between the WYSIWYG editor and the live design.

comment:6 usermrpapa4 years ago

lol - okay, but no use removing sidebars then... unless one likes empty white space...

comment:7 iammattthomas4 years ago

I've found that love of white space isn't the worst reason to do something. :) But there was a specific point: a request for an alternative page template to help users and budding theme builders understand the page templates feature. A page that removes the sidebar is about the simplest possible example of one.

comment:8 usermrpapa4 years ago

understand - wasn't for me. just prepping for our users that will ask how do they make our plugin (it's a forum) use all the available content width.

comment:9 nacin4 years ago

  • Milestone 3.0 deleted
Note: See TracTickets for help on using tickets.