WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 5 years ago

#12740 closed defect (bug) (fixed)

wp_handle_sideload should have unique filter name

Reported by: technosailor Owned by:
Milestone: 3.0 Priority: normal
Severity: normal Version: 3.0
Component: General Keywords:
Focuses: Cc:

Description

the wp_handle_sideload() functionhas the same filter, wp_handle_upload as the wp_handle_upload() function. This patch fixes that.

Attachments (3)

12740.diff (527 bytes) - added by technosailor 5 years ago.
12740-2.diff (1.5 KB) - added by technosailor 5 years ago.
Fair enough. 12740-2.diff adds context to existing hooks. Eats our own dogfood.
12740-3.diff (1.5 KB) - added by technosailor 5 years ago.

Download all attachments as: .zip

Change History (5)

@technosailor5 years ago

comment:1 @nacin5 years ago

  • Milestone changed from Unassigned to 3.0

wp_handle_upload is in xmlrpc as well. We should either add new per-function hooks (and not remove the current ones), or pass the function as a new argument to allow determination of context.

@technosailor5 years ago

Fair enough. 12740-2.diff adds context to existing hooks. Eats our own dogfood.

@technosailor5 years ago

comment:2 @nacin5 years ago

  • Resolution set to fixed
  • Status changed from new to closed

(In [14418]) Provide a context to wp_handle_upload to differentiate between upload and sideload. props technosailor, fixes #12740.

Note: See TracTickets for help on using tickets.