WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 4 years ago

#12778 closed defect (bug) (wontfix)

Cannot publish a post after clicking preview on Chrome/Safari

Reported by: grooveshark Owned by:
Milestone: Priority: normal
Severity: normal Version: 2.7
Component: Editor Keywords: close
Focuses: Cc:

Description

I am using 2.9.2, and my browsers are Chrome for Windows 7 and for Ubuntu 8.04.

When I am adding a new post, or editing an existing post, if I click on Preview, the Publish/Update buttons will no longer work. When I click the button, it will be stuck in the loading state, but the page will not actually load, and the changes will not be saved. This will only happen if the Preview button is clicked first.

Change History (8)

comment:1 follow-up: nacin4 years ago

I use Chrome on XP and don't have any problems. Since you're reporting this for 2.9.2, and there's no 2.9.3, I'm willing to bet that this is caused by a plugin mucking with something (and breaking that something).

Can you try disabling all plugins and see how that helps? If it fixes it, then enabling them one by one will lead you to the culprit.

comment:2 in reply to: ↑ 1 grooveshark4 years ago

Replying to nacin:

I use Chrome on XP and don't have any problems. Since you're reporting this for 2.9.2, and there's no 2.9.3, I'm willing to bet that this is caused by a plugin mucking with something (and breaking that something).

Can you try disabling all plugins and see how that helps? If it fixes it, then enabling them one by one will lead you to the culprit.

I disabled all plugins and still experienced the problem. Also tried it on a fresh 2.9.2 install and am still experiencing the problem.

comment:3 ocean904 years ago

  • Milestone changed from Unassigned to 3.0
  • Version set to 3.0

Can confirm it.

Open the browser, chrome in this case. Create a new post, add sth to title and to content, wait for the autosave. Then click on preview, it should open a new tab (it should switch automatically direct to the new tab). Then go to the other tab and click save, the loader graphic is shown but nothing else happens.

It works, if we didn't switch directly to the new tab. You can test it if you let the preview tab open. then create a new post, type some title and content, wait for autosave, click preview button. Now it should reload the preview tab, but not switch to it. Now click save and it saves.

Tested with chrome on win7.

comment:4 nacin4 years ago

  • Milestone changed from 3.0 to 2.9.3
  • Version changed from 3.0 to 2.9.2

Confirmed for Safari, Chrome, 2.9 branch. Could not reproduce on trunk, or in Opera, IE8, or Firefox.

comment:5 duck_4 years ago

I can reproduce with Chrome on Win7 using trunk, 2.9.2 and 2.7 (just for luck).

Seems that it might be a bug in WebKit (therefore by extension Chrome and Safari) and not an issue with WordPress. You cannot submit a form with the same action twice (see links).

A workaround (and to show that this is probably the issue) is to update the form's action field when previewing. Update wp-includes/js/autosave.js (line 53 in dev version):

$('form#post').attr('target', 'wp-preview').submit().attr('target', '').attr('action', 'post.php?'+Math.random());

NB: the issue was resolved for me when using Chrome 5.0.356.2 (from dev channel) on WordPress 2.9.2.

Further info:
http://www.google.com/support/forum/p/Chrome/thread?tid=4bb901d8189139df&hl=en
http://code.google.com/p/chromium/issues/detail?id=16528
https://bugs.webkit.org/show_bug.cgi?id=28633

comment:6 nacin4 years ago

  • Milestone changed from 2.9.3 to 3.0
  • Version changed from 2.9.2 to 2.7

Nice job tracking this down. Moving out of the point release milestone since you could reproduce back to 2.7.

This is a webkit bug, but it doesn't seem to be progressing well upstream. I like the idea of patching this if we can do so sensibly.

comment:7 nacin4 years ago

  • Keywords close added

Suggesting wontfix. Per discussion in IRC, this is fixed in WebKit trunk, so we can expect to see it in the stable releases of Safari and Chrome soon enough. It's been around a long time, not sure we need to implement a browser fix right before it'll get fixed anyway.

comment:8 nacin4 years ago

  • Milestone 3.0 deleted
  • Resolution set to wontfix
  • Status changed from new to closed

This is a regression in webkit, that has since been fixed upstream. It only breaks in a small number of browser versions, and those browsers generally have their stable releases adopted early and often by their users. Their stables soon or will have this fixed.

Closing as wontfix.

Note: See TracTickets for help on using tickets.