WordPress.org

Make WordPress Core

Opened 12 years ago

Closed 10 years ago

#12785 closed enhancement (fixed)

Add sorting and limit to default links widget

Reported by: yoavf Owned by: azaozz
Milestone: 3.4 Priority: normal
Severity: normal Version:
Component: Widgets Keywords: has-patch ux-feedback
Focuses: Cc:

Description

The default links widget is kinda dull, and to tell truth - he's really jealous of his brothers recent post and pages widgets.

So here's a little patch to add sorting order and limit to the widget.

Attachments (2)

sortable-links-widget.diff (7.2 KB) - added by yoavf 12 years ago.
refresh-sortables-links-widget.diff (7.2 KB) - added by yoavf 10 years ago.

Download all attachments as: .zip

Change History (11)

#1 @lancewillett
12 years ago

+1 - I've heard a lot of requests for this.

#2 @dd32
12 years ago

  • Keywords early added
  • Milestone changed from 3.0 to 3.1
  • Type changed from defect (bug) to enhancement

Sorry to have to be a pain, But since this isn't a regression, is an enhancement over what we've currently got & we're in a feature freeze, I'm going to bump this to early 3.1.

#3 @nacin
11 years ago

  • Keywords ux-feedback added; early removed
  • Milestone changed from Awaiting Triage to Future Release

Let's get Jane to weigh in on this before proceeding.

#4 follow-up: @yoavf
10 years ago

Refreshed patch for trunk.

#5 @jane
10 years ago

  • Milestone changed from Future Release to 3.3

Freeze has arrived. @rboren: I hear this has been running on .com for a while. Any issues? If you want to commit, its fine with me.

#6 in reply to: ↑ 4 @duck_
10 years ago

Replying to yoavf:

Refreshed patch for trunk.

WP_Widget_Links::widget() contains

$order = isset($instance['order']) ? $instance['order'] : 'ASC';

but order is not an option in the form and is never set on update.

I think that either the user should be allowed to choose the ordering via the form, or:

$order = 'rating' == $orderby ? 'DESC' : 'ASC';

#7 @ryan
10 years ago

  • Milestone changed from 3.3 to Future Release

Punting enhancements from 3.3.

#8 @ryan
10 years ago

  • Milestone changed from Future Release to 3.4

#9 @duck_
10 years ago

  • Resolution set to fixed
  • Status changed from new to closed

In [20071]:

Add sorting and limiting to the links widget. Props yoavf. Fixes #12785.

Note: See TracTickets for help on using tickets.