WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 3 months ago

#12789 closed defect (bug) (worksforme)

Inconsistent left or right margins on admin screens

Reported by: scribu Owned by:
Milestone: Priority: low
Severity: minor Version:
Component: Administration Keywords:
Focuses: ui Cc:

Description

There are a couple of admin screens where the screen icon is not aligned to the left of the content.

Attachments (6)

dashboard.jpg (22.3 KB) - added by scribu 4 years ago.
settings.jpg (20.2 KB) - added by scribu 4 years ago.
12789.diff (1.3 KB) - added by scribu 4 years ago.
dashboard CSS fix
12789-new.diff (357 bytes) - added by andrewryno 3 years ago.
list-table.png (13.5 KB) - added by scribu 2 years ago.
12789.2.diff (508 bytes) - added by helenyhou 17 months ago.

Download all attachments as: .zip

Change History (18)

scribu4 years ago

scribu4 years ago

comment:1 scribu4 years ago

  • Keywords has-patch needs-testing added

scribu4 years ago

dashboard CSS fix

comment:2 nacin4 years ago

  • Milestone changed from 3.0 to Future Release
  • Priority changed from normal to low
  • Severity changed from normal to minor

Incomplete patch, and the current patch for the dashboard will need to be confirmed for all browsers. (IE doesn't support adjacent selectors until v8 I think.) Very trivial, we can handle this in a future release.

comment:3 TECannon4 years ago

  • Cc TECannon added

comment:4 andrewryno3 years ago

Adding fix for dashboard page. Left margin inconsistency on settings page is due to padding on the table cell for the label. I think that might be addressed in #16413. Also, the icon may never exactly match up since some of the images are skinnier than the div and have extra space on either side once in a while. Don't know if left-aligning that image would be a good idea though.

This patch also doesn't rely on the adjacent selector, so it works in versions of IE as well.

Last edited 3 years ago by andrewryno (previous) (diff)

andrewryno3 years ago

comment:5 scribu2 years ago

It's actually worse now, since it doesn't allign with the new header either.

Last edited 2 years ago by scribu (previous) (diff)

comment:6 scribu2 years ago

Nevermind that last comment, I was on 3.2.

comment:7 scribu2 years ago

  • Keywords needs-patch added; has-patch needs-testing removed

comment:8 scribu2 years ago

  • Summary changed from Inconsistent left margin on admin screens to Inconsistent left or right margins on admin screens

scribu2 years ago

comment:9 scribu2 years ago

Notice the misalignment between:

  • the user avatar (-2px)
  • the help tab (9px)
  • the search button (1px)
  • the pagination button (1px)
  • the table

http://core.trac.wordpress.org/raw-attachment/ticket/12789/list-table.png

Version 1, edited 2 years ago by scribu (previous) (next) (diff)

helenyhou17 months ago

comment:10 helenyhou17 months ago

  • Component changed from UI to Administration

Going through old tickets. What still remains? I only see that the screen meta stuff isn't aligned on either side. Added a patch for that, since I was looking at it already.

comment:11 obenland4 months ago

  • Keywords close added

Is this still applicable with the new UI? Screen meta stuff looks aligned now.

comment:12 ocean903 months ago

  • Focuses ui added
  • Keywords needs-patch close removed
  • Milestone Future Release deleted
  • Resolution set to worksforme
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.