WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 3 years ago

Last modified 3 years ago

#12802 closed defect (bug) (invalid)

Editing with Quick Edit changes author when logged in as author role or lower

Reported by: lancewillett Owned by:
Milestone: Priority: normal
Severity: major Version: 3.0
Component: Quick/Bulk Edit Keywords:
Focuses: Cc:

Description

I saw an odd behavior in the Quick Edit menu when logged in as Author or lower role.

What I did:
Logged in as an Author user, opened up Edit Posts, and used the "Quick Edit" link to add a tag to a post. (The post was written by an adminstrator-level user.)

What I expected to happen:
Save the tag data only -- I expected the rest of the fields to remain as they were, including the original post author.

What actually happened:
The post author was changed to my user (the logged in Author user) instead of the original post author.

Possibly related?

Change History (9)

comment:1 miqrogroove4 years ago

  • Priority changed from low to normal
  • Severity changed from normal to major

This is a major issue if WP is allowing authors to take ownership of posts.

comment:2 miqrogroove4 years ago

lancewillett, under what circumstance is WP showing the Quick Edit interface to authors on posts they do not already own? I've never seen that happen.

comment:3 nacin4 years ago

  • Keywords reporter-feedback added; 2nd-opinion removed

As an author or below, you can only edit your own posts, and that includes via Quick Edit.

comment:4 lancewillett4 years ago

  • Cc lance@… added

comment:5 lancewillett4 years ago

  • Keywords reporter-feedback removed
  • Resolution set to invalid
  • Status changed from new to closed

Thanks for the feedback. I did more testing and confirmed that as an author or lower I am not able to edit posts (including Quick Edit) using latest trunk with r14075.

I tracked this down to a bug in WordPress MU: http://trac.mu.wordpress.org/ticket/1093 -- so was never a bug in core WordPress. Sorry for the confusion -- I'm closing the ticket.

comment:6 miqrogroove4 years ago

Also noting the MU ticket is closed:fixed at 2.9. Thanks for the link.

comment:7 skcsknathan0013 years ago

  • Cc skcsknathan001 added
  • Resolution invalid deleted
  • Status changed from closed to reopened
  • Version changed from 3.0 to 3.2.1

The same bug appears when an Admin does the QuickEdit. Now the original author is replaced with the Admin username.

Sorry, my mistake. It was caused by the plugin: Co-Authors Plus

Last edited 3 years ago by skcsknathan001 (previous) (diff)

comment:8 skcsknathan0013 years ago

  • Resolution set to invalid
  • Status changed from reopened to closed

comment:9 SergeyBiryukov3 years ago

  • Version changed from 3.2.1 to 3.0
Note: See TracTickets for help on using tickets.