WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 5 years ago

#12813 closed defect (bug) (fixed)

Importer multiplies category with non-ASCII name

Reported by: demetris Owned by:
Milestone: 3.0 Priority: normal
Severity: normal Version: 3.0
Component: Import Keywords:
Focuses: Cc:

Description

Happens in current trunk (r13945) with WRX produced by same revision.

Confirmed on two different fresh setups, Windows/Apache and Debian.

DESCRIPTION

One of the categories in the import file has a Greek name, an ASCII slug, and 10 posts.

WordPress imports the category one time with the correct name and slug but with no posts, and then makes another 10 categories with the same name, with slugs sequentially numbered, and with 1 post in each (that is, in total, the 10 posts that belong to the category).

See attached screenshot if you are not with me by now. :-)

If the cause is difficult to find, maybe I can help by trying to find the revision the issue first appeared.

Attachments (1)

wp-30-r13945-import-result.png (21.7 KB) - added by demetris 5 years ago.
Multiplication of category by WP importer

Download all attachments as: .zip

Change History (3)

@demetris5 years ago

Multiplication of category by WP importer

comment:1 @ryan5 years ago

  • Milestone changed from 3.0 to 3.1

comment:2 @demetris5 years ago

  • Milestone changed from 3.1 to 3.0
  • Resolution set to fixed
  • Status changed from new to closed

Seems to be fixed as of r14842.

(Probably caused by #12349, which was fixed.)

Note: See TracTickets for help on using tickets.