WordPress.org

Make WordPress Core

Opened 11 years ago

Closed 11 years ago

#12841 closed defect (bug) (invalid)

White screen after clicking Tools -> Network

Reported by: erunafailaro Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.0
Component: General Keywords: network, wsod
Focuses: Cc:

Description

After upgrading my WP 2.9.2 to 3.0-beta1 and adding define ('WP_ALLOW_MULTISITE', true ) ; to my wp-config.php I can see the link Network in my tools-menu.

But clicking on it causes a white screen of death.

All my plugins were disabled before clicking on the network-link.

I'm sure you'll need further information to investigate this issue. Please tell me what is missing or if you need to take a look at my server directly.

Attachments (2)

info.php.html (60.6 KB) - added by erunafailaro 11 years ago.
output of phpinfo()
debug_20100404_2000.txt (10.4 KB) - added by erunafailaro 11 years ago.
debug output

Download all attachments as: .zip

Change History (7)

@erunafailaro
11 years ago

output of phpinfo()

#1 @dd32
11 years ago

can you try adding this to your wp-config.php file and see if you've got any php errors showing?

define('WP_DEBUG', true);

@erunafailaro
11 years ago

debug output

#2 @erunafailaro
11 years ago

Among a lot of notices and warnings, there is this:

Fatal error: Call to undefined method wpdb::tables() in /www/htdocs/v151372/wp-admin/network.php on line 23

Is there a file missing on my installation? Why is wpdb::tables() undefined?

#3 @erunafailaro
11 years ago

  • Cc erunafailaro added
  • Resolution set to fixed
  • Status changed from new to closed

I had to deactivate the plugin DB Cache Reloaded. But that alone is not enough: I had to remove two files belonging to this plugin:

  • /wp-config/db-config.ini
  • /wpconfig/db.php

Now the issue is solved for me. Perhabs you should include this info in the WP-upgrade-instructions.

#4 @nacin
11 years ago

  • Resolution fixed deleted
  • Status changed from closed to reopened

Generally speaking, db.php drop-ins may need to be updated with each release, as generally there are modifications to the wpdb class. In 3.0 in particular, we made substantial changes to wpdb to support the merge of MU.

DB Cache Reloaded entirely replaces the wpdb class, instead of extending it, so any methods we add will not be inherited by it. Hence, the tables() method did not exist. (Though, even a db drop-in that extends wpdb may not be able to function correctly in a newer version.)

#5 @nacin
11 years ago

  • Resolution set to invalid
  • Status changed from reopened to closed
Note: See TracTickets for help on using tickets.