WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 3 years ago

#12858 closed enhancement (duplicate)

Improve wp_trim_excerpt by separate trim text feature and excerpt specificity

Reported by: momo360modena Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Formatting Keywords:
Focuses: Cc:

Description

Create a new function wp_trim_text() and use it for wp_trim_excerpt().

Attachments (1)

formatting.php.patch (2.2 KB) - added by momo360modena 4 years ago.

Download all attachments as: .zip

Change History (6)

comment:1 nacin4 years ago

  • Milestone changed from 3.0 to Future Release

comment:2 momo360modena4 years ago

This modification is really minor.

I see not why she could not be integrated into the version 3.0

comment:3 nacin4 years ago

We are in feature freeze for 3.0, nor is this a minor modification.

We'd be introducing a new function that a major filter would use. It would not only need to be thoroughly reviewed, but also analyzed for whether it makes sense for the most number of users and developers as written.

comment:4 momo360modena4 years ago

It's true...

But the final behavior is the same, thus the side effects are more than limited.

comment:5 sivel3 years ago

  • Keywords has-patch needs-testing removed
  • Milestone Future Release deleted
  • Resolution set to duplicate
  • Status changed from new to closed
  • Version 3.0 deleted

Closing as a duplicate of #16372. The patch on that ticket seems more reasonable.

Note: See TracTickets for help on using tickets.