WordPress.org

Make WordPress Core

Opened 11 years ago

Closed 10 years ago

#12863 closed defect (bug) (fixed)

jQuery UI 1.8

Reported by: ocean90 Owned by: koopersmith
Milestone: 3.1 Priority: normal
Severity: normal Version: 3.0
Component: JavaScript Keywords: jquery early has-patch
Focuses: Cc:

Description

For some days jQuery UI 1.8 is published. We should update it in the core too.

For 3.0 I think its to late, so maybe 3.1.

Attachments (3)

r12863-jquery-ui-185.diff (214.4 KB) - added by demetris 10 years ago.
jQuery UI update from 1.7.3 to 1.8.5
t12863-jquery-ui-185-to-184.diff (87.6 KB) - added by demetris 10 years ago.
jQuery UI downgrade from 1.8.5 to 1.8.4
verify-draggability.12863.diff (498 bytes) - added by filosofo 10 years ago.

Download all attachments as: .zip

Change History (22)

#1 @koopersmith
10 years ago

When we do this, we should replace our autocomplete jQuery plugin with the new jQ UI one (which is built on top of the one we're using).

#2 @bigdawggi
10 years ago

  • Cc matt@… added
  • Keywords ui added
  • Milestone changed from 3.1 to 3.0
  • Type changed from enhancement to defect (bug)
  • Version set to 3.0

I'm seeing jQuery UI Tabs broken in the current 3.0b2. When testing by updating jQuery UI Core to 1.8.1 and updating the jQuery UI Tabs to 1.8.1 it works.

It'd be nice if this was remedied in 3.0, but I can de-register the Core and Tabs and include the latest for the plugin I'm writing for a client if that's not possible.

Kicking the Milestone back to 3.0, and setting Type to "bug", to let someone review and decide if it needs to be fixed in 3.0 or 3.1

#3 @ryan
10 years ago

  • Keywords early added; ui removed
  • Milestone changed from 3.0 to 3.1

There's no time to retest everything for 3.0. We'll get this early 3.1.

#4 @aaroncampbell
10 years ago

  • Cc aaron@… added

#5 @ramoonus
10 years ago

1.8.4 has been released a day or two ago.

@demetris
10 years ago

jQuery UI update from 1.7.3 to 1.8.5

#6 @demetris
10 years ago

Though barely qualified to be making this patch, I thought it would be good to have it in sooner than later, so I tried my hand at it.

I am running it on two different setups and haven’t noticed anything broken yet.

#7 @demetris
10 years ago

  • Keywords has-patch added

#8 @nacin
10 years ago

  • Milestone changed from Awaiting Triage to 3.1
  • Owner changed from azaozz to koopersmith
  • Status changed from new to assigned

#9 @hakre
10 years ago

I think this needs a lot of testing. And we don't have any tests for it as far as I remember. So good to have a patch now!

#10 @ryan
10 years ago

  • Resolution set to fixed
  • Status changed from assigned to closed

(In [15711]) jQuery UI 1.8.5. Props demetris. fixes #12863

#11 follow-up: @chrisbliss18
10 years ago

  • Resolution fixed deleted
  • Status changed from closed to reopened

I find that [15711] breaks all widget functionality. After applying this changeset, widgets can no longer be created using drag-and-drop (non-accessibility mode). Any time a new widget is dragged into a sidebar location, the following error is generated:

uncaught exception: cannot call methods on draggable prior to initialization; attempted to call method 'destroy'

This changeset should be reverted until proper testing can find and correct this issue.

#12 @chrisbliss18
10 years ago

Correction. I said in my previous comment "breaks all widget functionality". I meant to say that changeset [15711] breaks all widget creation functionality. Removing, modifying, and reordering widgets works as expected.

#13 @demetris
10 years ago

A quick search tells me that the issue is specific to jQuery UI v1.8.5. It did not exist in v1.8.4 and it is fixed in v1.8.6 (not released yet).

More: http://dev.jqueryui.com/ticket/6069

#14 in reply to: ↑ 11 ; follow-up: @nacin
10 years ago

Replying to chrisbliss18:

This changeset should be reverted until proper testing can find and correct this issue.

We generally wouldn't want to do that. Trunk is not stable, and leaving it committed will help us find other issues.

I'm not sure of the timeline of 1.8.6 but I imagine it'll be out soon. I suggest we apply this patch to our 1.8.5 for now. http://github.com/jquery/jquery-ui/commit/98a98a05d1a646a1e53b90020fe7c096acd1d933

#15 in reply to: ↑ 14 @chrisbliss18
10 years ago

Replying to nacin:

leaving it committed will help us find other issues.

True.

Replying to nacin:

I suggest we apply this patch to our 1.8.5 for now. http://github.com/jquery/jquery-ui/commit/98a98a05d1a646a1e53b90020fe7c096acd1d933

Agreed. I simply don't want a situation where proper widget testing is shelved until jQuery UI 1.8.6 is released.

#16 @demetris
10 years ago

I played a bit with jQuery UI files updated since v1.8.5 (ui.dialog.js plus another three) but had no luck. Either I am doing something wrong or there is still some issue. This needs to be looked at by one of our JavaScript experts.

Downgrading jQuery UI from v1.8.5 to v1.8.4 fixes the issue for me. I am attaching the downgrade patch for anyone who wants to check.

@demetris
10 years ago

jQuery UI downgrade from 1.8.5 to 1.8.4

#17 @filosofo
10 years ago

verify-draggability.12863.diff verifies that the item is actually draggable before trying to strip it of its draggability.

#18 @nacin
10 years ago

(In [15738]) Verify that a widget is draggable before stripping its draggability. props filosofo, see #12863. Fixes widget creation for jQUI 1.8.5; should be fixed in jQUI 1.8.6.

#19 @nacin
10 years ago

  • Resolution set to fixed
  • Status changed from reopened to closed
Note: See TracTickets for help on using tickets.