Make WordPress Core

Opened 6 years ago

Closed 6 years ago

#12878 closed defect (bug) (fixed)

r14015 breaks TB_iframe

Reported by: demetris Owned by: scribu
Milestone: 3.0 Priority: normal
Severity: normal Version: 3.0
Component: JavaScript Keywords: has-patch
Focuses: Cc:


Since r14015, on two different setups, at two different places:

  • In Plugins, Upgrade Available, clicking on “View version details” does nothing
  • In Themes, clicking on “Preview” does nothing.

Attachments (1)

12878.diff (3.6 KB) - added by scribu 6 years ago.
open the thickbox first, then make modifications

Download all attachments as: .zip

Change History (4)

#1 @scribu
6 years ago

  • Owner changed from azaozz to scribu
  • Status changed from new to accepted

6 years ago

open the thickbox first, then make modifications

#2 @scribu
6 years ago

  • Keywords has-patch added

The problem was caused by using the .live() method: delegated events fire after normal events.

#3 @markjaquith
6 years ago

  • Resolution set to fixed
  • Status changed from accepted to closed

(In [14030]) TB_iframe fixes for stuff that broke in r14015. props scribu. fixes #12878. see #12792

Note: See TracTickets for help on using tickets.