WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 4 years ago

Last modified 4 years ago

#12897 closed defect (bug) (duplicate)

page is treated as category when premalink are set to %category%

Reported by: liorsion Owned by: ryan
Milestone: Priority: high
Severity: major Version: 2.9.2
Component: Permalinks Keywords: needs-testing
Focuses: Cc:

Description

If I set my premalinks to %category%/%whatever%/ and I'm not using english (tested in Hebrew), all pages (that are also in Hebrew) are getting 404 not found since they are treated as categories and not pages - effectively rendering the %category% permalink impossible to use.

The bug lies in classes.php line 172:

$req_uri = str_replace($pathinfo, , rawurldecode($req_uri));

the rawurldecode should be removed.

I didn't want to actively fix it to avoid issues I might not be aware of.. please pay attention before removing this.

Change History (6)

comment:1 @scribu5 years ago

  • Milestone changed from 2.9.3 to 3.0
  • Version set to 2.9.2

comment:2 @dd325 years ago

  • Keywords needs-testing added
  • Milestone changed from 3.0 to Future Release

Punting based on no patch and no testing done.

comment:3 @tomer5 years ago

  • Cc tomer added

comment:4 @SergeyBiryukov5 years ago

Isn't it a duplicate of #10249?

comment:5 @SergeyBiryukov4 years ago

  • Resolution set to duplicate
  • Status changed from new to closed

Looks like it is. #10249 has a couple of patches.

comment:6 @ocean904 years ago

  • Milestone Future Release deleted
Note: See TracTickets for help on using tickets.