WordPress.org

Make WordPress Core

Opened 5 years ago

Last modified 7 months ago

#12900 reopened enhancement

Enhance Nav_Menu to use the older menu functions

Reported by: WraithKenny Owned by:
Milestone: Future Release Priority: normal
Severity: normal Version:
Component: Menus Keywords:
Focuses: Cc:

Description

Concerning wp_list_pages, wp_page_menu, and/or wp_list_categories functions:

Since these functions exists and developers are comfortable with them, and they'd add much functionality if they were included in the new wp_nav_menu function.

Could the wp_nav_menu utilize these established functions in itself to allow "dynamic" listing of pages with the useful options available in those functions?

New "widgets" on the left among the "Add Existing Page" and "Add an Existing Category" (perhaps "Add Dynamic Page List" or the like) that would essentially be a UI interface for the args that the wp_list_pages, wp_page_menu, or wp_list_categories functions already accept. The wp_nav_menu would then pass those args to the appropriate function and create items in the appropriate place in the nav menu. (I have no idea how easy/hard that'd be.)

This wouldn't replace the "Add Existing Page" or "Add an Existing Category" as starting at zero and adding individual items is different and also very useful.

This treatment might be appropriate for any function listed in "Related" http://codex.wordpress.org/Template_Tags/wp_list_pages#Related or maybe only wp_page_menu or wp_list_pages. I think it warrants discussion.

P.S. This is well above my ability in PHP. I don't think I can't do a working patch on this :-(

Change History (13)

comment:1 @WraithKenny5 years ago

  • Cc Ken@… added

comment:2 @ptahdunbar5 years ago

  • Owner changed from ryan to ptahdunbar
  • Status changed from new to accepted

Allowing developers to create their own type of menu item isn't the easiest given the way the current system works. I'm working on fixing that, but that'll be for 3.1.

comment:3 @mikeschinkel5 years ago

  • Cc mikeschinkel@… added

Add capability to add a menu as a menuitem to be a submenu thus allowing multiple menu items to share the same submenus.

comment:5 @WraithKenny5 years ago

#14969 related/duplicate

comment:6 @nacin5 years ago

  • Milestone changed from Awaiting Triage to Future Release

comment:7 @ptahdunbar4 years ago

  • Owner ptahdunbar deleted
  • Status changed from accepted to assigned

comment:8 @WraithKenny4 years ago

  • Resolution set to worksforme
  • Status changed from assigned to closed

http://www.viper007bond.com/wordpress-plugins/add-descendants-as-submenu-items/

Alex wrote a plugin that basically solves this so I'll close the ticket. Works for Me :)

comment:9 @SergeyBiryukov4 years ago

  • Milestone Future Release deleted

comment:10 @Viper007Bond4 years ago

  • Milestone set to Future Release
  • Resolution worksforme deleted
  • Status changed from closed to reopened

I think this functionality is worthy of being in core. Who wants to manually maintain submenu items? :)

comment:11 @WraithKenny4 years ago

that also sounds good to me, +1

comment:12 @chriscct77 months ago

  • Keywords dev-feedback added

Anyone got any thoughts on this?

comment:13 @celloexpressions7 months ago

  • Keywords dev-feedback removed

If 8 is all that is left for this ticket, this is a duplicate of another more updated (possibly patched) ticket somewhere (although I can't find it).

Note: See TracTickets for help on using tickets.