WordPress.org

Make WordPress Core

Opened 10 years ago

Closed 7 years ago

Last modified 6 years ago

#12929 closed enhancement (duplicate)

Reserved names for taxonomies

Reported by: scribu Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Taxonomy Keywords:
Focuses: Cc:

Description

To prevent issues like #12917, register_taxonomy() should check a list of reserved names, before registering the taxonomy.

Change History (12)

#1 @scribu
10 years ago

First of all, the list should contain the names of registered post types. I know from experience that having the same name for a post type and for a taxonomy leads to trouble.

#2 @mikeschinkel
10 years ago

  • Cc mikeschinkel@… added

Should new reserved names moving forward be prefixed with underscore, maybe?

#3 @filosofo
10 years ago

  • Owner changed from filosofo to scribu
  • Status changed from new to assigned

#4 @kevinB
10 years ago

  • Cc kevinB added

#5 @nacin
10 years ago

  • Milestone changed from Awaiting Triage to Future Release

#6 @scribu
8 years ago

  • Owner scribu deleted

#7 @WraithKenny
8 years ago

  • Cc Ken@… added

#9 @WraithKenny
8 years ago

I spent some time thinking about this one, and decided it'd make a good Debug Bar extension. There's a hook in register_taxonomy that can be used to setup checks for reserved names. Post type conflicts should be checked later in the execution. Debug Bar would be a great place to output the results.

#10 @helen
8 years ago

#23213 was marked as a duplicate.

#11 @wonderboymusic
7 years ago

  • Milestone Future Release deleted
  • Resolution set to duplicate
  • Status changed from assigned to closed

Duplicate of #11531.

There are a bunch of tickets that all say basically the same thing, closing out this one as dupe

#12 @SergeyBiryukov
6 years ago

#31155 was marked as a duplicate.

Note: See TracTickets for help on using tickets.