WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 4 years ago

#12938 closed defect (bug) (fixed)

Autosave draft page deletes parent_id

Reported by: duck_ Owned by: azaozz
Milestone: 3.0 Priority: normal
Severity: normal Version: 2.7
Component: Autosave Keywords: has-patch
Focuses: Cc:

Description

Create a new page. Add title, content and set a parent page. Save draft and then wait for autosave. Reload the page.

Actual: Parent page is reset to Main page (no parent)

Expected: Parent page should stay the same

This is caused by drafts being completely overwritten by autosaves (not just title, content, excerpt) combined with no parent_id being sent by autosave.js.

Attachments (1)

autosave.dev.js.diff (605 bytes) - added by duck_ 4 years ago.

Download all attachments as: .zip

Change History (2)

duck_4 years ago

comment:1 dd324 years ago

  • Resolution set to fixed
  • Status changed from new to closed

(In [14057]) Remember the post_parent during autosaves. Props duck_. Fixes #12938

Note: See TracTickets for help on using tickets.