Make WordPress Core

Opened 6 years ago

Closed 6 years ago

#12941 closed defect (bug) (fixed)

do_action(get_template_part{$slug}) could use and underscore or dash for better readability

Reported by: ev3rywh3re Owned by: nacin
Milestone: 3.0 Priority: normal
Severity: normal Version: 3.0
Component: Template Keywords: has-patch
Focuses: Cc:


in [13815] the function and action were renamed, but that removed the underscore in the do_action part. Attached is a quick patch to bring back the underscore in the action name for (hopefully!) better consistency and readability. I'm marking as a defect since leaving off the underscore may have been accidental.

Attachments (1)

get_template_part-r14044.txt (503 bytes) - added by ev3rywh3re 6 years ago.
Patch to bing back underscore to get_template_part action

Download all attachments as: .zip

Change History (4)

6 years ago

Patch to bing back underscore to get_template_part action

#1 @ev3rywh3re
6 years ago

  • Keywords has-patch added

#2 @nacin
6 years ago

  • Keywords get_template_part removed
  • Owner set to nacin
  • Status changed from new to accepted

My guess is just a typo.

#3 @nacin
6 years ago

  • Resolution set to fixed
  • Status changed from accepted to closed

(In [14047]) Tweaks to the action in get_template_part(). fixes #12248, fixes #12941.

Note: See TracTickets for help on using tickets.