WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#12944 closed defect (bug) (wontfix)

Post status cannot be changed without publish_posts cap

Reported by: sbressler Owned by:
Milestone: Priority: normal
Severity: normal Version: 2.9.2
Component: Administration Keywords:
Focuses: Cc:

Description

Post statuses cannot be changed without the publish_posts capability. I think it would make more sense to limit status changes to users with edit_posts or edit_others_posts.

Change History (3)

comment:1 nacin4 years ago

Are you referring to custom stati? The current capabilities are enough to handle the built-in statuses.

future and publish require publish caps. pending and draft requires edit_posts. trash and private depend on the situation.

comment:2 markjaquith4 years ago

  • Resolution set to wontfix
  • Status changed from new to closed

This is by design.

comment:3 nacin4 years ago

  • Milestone Unassigned deleted
Note: See TracTickets for help on using tickets.