WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 4 years ago

#12948 closed defect (bug) (worksforme)

Post tags using cyrillic chars multiply in tables wp_term* when updating posts

Reported by: StefanMz Owned by:
Milestone: Priority: normal
Severity: major Version: 2.9.2
Component: Charset Keywords: reporter-feedback
Focuses: Cc:

Description

Having the post tag български (with slug bulgarski) and saving changes on a post using this tag, the tag is not recognized as already existent (not increasing "count" in wp_term_taxonomy), but recreated in tables wp_terms, wp_term_taxonomy, and wp_term_relationships again and again.

My observation is, that the previous entry in wp_term_taxonomy linking the existing term with the last post version is replaced by a new entry linking the redundant new term and the post.

The same behavior occurs when using HTML-entities instead of the cyrillic characters български.

MySQL database, db-connection and tables use utf8_general_ci.

Change History (5)

comment:1 filosofo4 years ago

  • Owner filosofo deleted
  • Status changed from new to assigned

comment:2 nacin4 years ago

  • Component changed from Taxonomy to Charset

I imagine this is a duplicate of another few tickets out there.

comment:3 SergeyBiryukov4 years ago

Can't reproduce. Do you use a plugin for transliterating slugs, e.g. Rus-To-Lat?

comment:4 SergeyBiryukov4 years ago

  • Keywords reporter-feedback added

comment:5 westi4 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to worksforme
  • Status changed from assigned to closed

I can't reproduce this either.

Note: See TracTickets for help on using tickets.