Make WordPress Core

Opened 10 years ago

Closed 9 years ago

#1296 closed defect (bug) (fixed)

New registered users have 'not-deletable' http:/// URL als Homepage

Reported by: Syn Owned by:
Milestone: Priority: normal
Severity: minor Version: 1.5
Component: General Keywords:
Focuses: Cc:


Strange thing. Registered users with no homepage specified are shown as they have a homepage linked to http:///
This is wierd, i created a testuser, he had this URL too, i deleted the URL at the Admin Panel, saved and http:// was back again, not deletably.
I tried another user, same process, http:/// while registering but i COULD delete it at the Admin CP and it was erased.
Sometimes it works and sometimes it doesn't.

Only one Plugin is working:
Mail Obfuscator (http://www.blackbirdblog.it/programmazione/progetti/25)

Change History (8)

#1 @Syn
10 years ago

  • Patch set to No

#2 @anonymousbugger
10 years ago

Same issue here....

#3 @anonymousbugger
10 years ago

Not logged it, but its me, Syn, the topicstarter :)

Well i modified the Script and solved the problem by myself.

There are only two small modifications.

Goto WP-ADMIN and open USER-EDIT.PHP, goto line 61, you see there
$new_url = preg_match('/(https?|ftps?|mailto|news|gopher):/is', $new_url) ? $new_url : 'http://' . $new_url;
Write UNDER this line the following code
$new_url = $new_url=='http://'?'':$new_url;

Goto WP-ADMIN , open the file PROFILE.PHP, goto line 79, it looks like
$newuser_url = preg_match('/(https?|ftps?|mailto|news|gopher):/is', $newuser_url) ? $newuser_url : 'http://' . $newuser_url;
add UNDER this line the following Code
$newuser_url = $newuser_url=='http://'?'':$newuser_url;

(IMPORTANT: the Code for profile.php is not the same as for user-edit.php)

Upload both Scripts into your Blogfolder/WP-ADMIN.

That's all, i know its not the best way, but i didnt want to start messing around with the regular expression there what seems to work incorrect.

Additional Note, i don't know why, but all Users with this 'wrong' Website are still in the blog, only new entries are fixed - i hope so.
I guess the blog generates some sort of static / cached Version

edited on: 04-30-05 13:18

#4 @anonymousbugger
10 years ago

I have these problemes as well.

I applied the fix above and it did work (I can save a user profile without the http://) but I have the same caching issue because any change made (removing the url or adding a correct url) doesn't reflect on the blog.

#5 @Syn
10 years ago

This is not a bug, the comments DB saves every user entry for every single comment.
As you can see it in the wp_comments table.
The cause is that you can usually write a comment as a non registered user, so those users occur only one time and the WP writes everytime a static entry of your mail and URL and so on.
For registered users it would be better to make a refrence to their details, but WP does not distinguish between them.
I guess we have to live with that.
There are other problems here

edited on: 05-05-05 10:14

#6 @anonymousbugger
10 years ago

Ok, thanks. I didn't know WP worked that way.

#7 @rob1n
9 years ago

Yes, wordpress doesn't link users' info (username, user email, user URL) from comments to the user table, apart from referencing the user with a user_ID field.

#8 @johnbillion
9 years ago

  • Resolution set to fixed
  • Status changed from new to closed

Resolved as fixed. Not sure when it was fixed, but it has been.

Note: See TracTickets for help on using tickets.