WordPress.org

Make WordPress Core

Opened 10 years ago

Closed 10 years ago

#12994 closed defect (bug) (fixed)

Threaded Comments Breaks Layout in Twenty Ten Theme

Reported by: mrgtb Owned by: iammattthomas
Milestone: 3.0 Priority: normal
Severity: normal Version: 3.0
Component: Themes Keywords:
Focuses: Cc:

Description

I've noticed with the new Twenty Ten theme, that if you post a "Threaded Comment" it break the layout. By that I posts a reply to a reply already posted.

Attachments (1)

Snap1.jpg (49.8 KB) - added by mrgtb 10 years ago.

Download all attachments as: .zip

Change History (15)

#1 @markmcwilliams
10 years ago

  • Keywords Theme Twenty Ten removed
  • Milestone changed from 3.1 to 3.0
  • Owner set to iammattthomas
  • Status changed from new to assigned

Have you got a screenshot of the particular issue you're facing? TwentyTen has been out in the wild for a while now, and people have been using the Threaded Comments on offer, maybe something they've missed? - If you could upload a photo, that'd be a start in helping anyway! :)

#2 @mrgtb
10 years ago

OK, I'll install it again later and take a screen-shot and upload it here

@mrgtb
10 years ago

#3 @mrgtb
10 years ago

You can test it breaking the layout on my blog here by making a reply to my comment: http://mrgtb.com/blog

I've just added an attachment

#4 @markmcwilliams
10 years ago

  • Keywords dev-feedback added

It'll not allow me to test out the Threaded Comments, it'd appear they're not enabled on your site at the moment? OK I can see from the attachment what you mean, but I also just checked on a few other sites running TwentyTen and couldn't duplicate the error you're seeing either!

When making (whatever) changes you made to the design, have you in any way touched the CSS code? That's about all I can think about right now!

#5 @mrgtb
10 years ago

I disabled it today, let me re-enable it again so you can test it

#6 @nacin
10 years ago

  • Keywords reporter-feedback added; dev-feedback removed

Browser/OS?

#7 @mrgtb
10 years ago

No I have not altered any CSS code, only changed colours used by it only. Nothing new has been added or changed to effect how things work using CSS. This was happening to me anyway using the default style with no changes at all made it, that's how I first spotted it. This wasn't something that started happening only after I customised the Twenty Ten theme.

I've also install WordPress 3 about 3-4 times now, both live and on my localhost using Wamp. The same problem all the time in both cases.

#8 @mrgtb
10 years ago

Some extra information here. I just noticed if I use Internet Explorer 8 all if fine, but it happening using the latest version of FireFox

#9 @nacin
10 years ago

  • Keywords reporter-feedback removed
  • Owner changed from iammattthomas to nacin
  • Status changed from assigned to accepted

confirmed.

#10 @nacin
10 years ago

  • Owner changed from nacin to iammattthomas
  • Status changed from accepted to assigned

Looks like it's a difference in how Firefox and other browsers render borders, at least on Windows where I am testing.

Firefox provides the same two-border inset default to textareas and inputs. I'm seeing Webkit and IE8 give textareas only one pixel.

To account for that, it looks like it was designed in Safari, as textareas are width 99%, instead of 98% like inputs. But for them to look exact in Firefox, they should be 98%.

For this to be entirely cross-browser, we'd have to actually style them with our own borders. To simply fix the issue at hand as it presents itself in Firefox, we should reduce it to 98%, but that prevents it from looking as good as it does now in Webkit as the textarea will technically be a few pixels shorter than the others.

Committing 98% then assigning to MT for a review.

#11 @nacin
10 years ago

(In [14115]) Twentyten: Prevent right edge of the comment textarea from being hidden from view in Firefox. see #12994

#12 follow-up: @markmcwilliams
10 years ago

So we're good to be closed now, or still waiting for MT to review?

#13 in reply to: ↑ 12 @nacin
10 years ago

Replying to markmcwilliams:

So we're good to be closed now, or still waiting for MT to review?

I'll wait for MT here.

#14 @iammattthomas
10 years ago

  • Resolution set to fixed
  • Status changed from assigned to closed

Thanks Nacin; the widths look good. I've updated textareas and text inputs in r14201 so that they all have uniform styles, too.

Note: See TracTickets for help on using tickets.