WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 4 years ago

#13013 closed defect (bug) (duplicate)

Installing plugins / themes from admin fails with memory exhausted...

Reported by: flashingcursor Owned by: dd32
Milestone: Priority: normal
Severity: major Version: 3.0
Component: Filesystem API Keywords:
Focuses: Cc:

Description

Installing any plugin, theme and trying to use the beta-testing plugin to update to the newest nightly using a clean install of the 04/15 and 04/16 nightly produce the same error:

Example:

Downloading install package from http://downloads.wordpress.org/plugin/dynamic-content-gallery-plugin.3.2.3.zip

Unpacking the package…

Fatal error: Allowed memory size of 134217728 bytes exhausted (tried to allocate 25581 bytes) in /home/admin/domains//public_html/wp-includes/formatting.php on line 1195

Change History (7)

comment:1 ocean904 years ago

See also #12057.

Which memory_limit do you have? It should be 32M at minimum.

comment:2 follow-up: nacin4 years ago

  • Owner changed from westi to dd32
  • Status changed from new to assigned

No, he's using a limit of 128MB.

1195 is untrailingslashit(), which is simply a wrapper for rtrim. Clearly not where the memory exhaustion is taking place.

We've made some changes to unzip_file() in the 3.0 dev cycle so I'm going to assign this to dd32 but also set reporter-feedback on it, as we'll need more information about your setup. A note, unzip_file() does attempt to boost the memory limit to 256.

comment:3 nacin4 years ago

  • Component changed from Plugins to Filesystem

comment:4 in reply to: ↑ 2 flashingcursor4 years ago

Replying to nacin:

We've made some changes to unzip_file() in the 3.0 dev cycle so I'm going to assign this to dd32 but also set reporter-feedback on it, as we'll need more information about your setup. A note, unzip_file() does attempt to boost the memory limit to 256.

Please let me know what additional information you need and I'll be happy to help.

comment:5 dd324 years ago

  • Milestone changed from Unassigned to 3.0
  • Priority changed from high to normal
  • Severity changed from blocker to major

Can you post a copy of your phpinfo() output? or alternativly, email it to me off-trac? wordpress/at/dd32.id.au

Reducing the priority as at this point in time, its not a widespread issue.

comment:6 flashingcursor4 years ago

Sent phpinfo via email

comment:7 dd324 years ago

  • Milestone 3.0 deleted
  • Resolution set to duplicate
  • Status changed from assigned to closed

Can you SVN up? This should be fixed i hope.

Closing as duplicate of #12057

Note: See TracTickets for help on using tickets.