Make WordPress Core

Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#13015 closed enhancement (duplicate)

Custom post types with rewrite doesn't have loop page

Reported by: grezvany13 Owned by:
Milestone: Priority: normal
Severity: trivial Version: 3.0
Component: Posts, Post Types Keywords:
Focuses: Cc:


note: not sure if bug, feature request or enhancement... or current feature

When using custom post types with rewrite, the slug itself can't be accessed.


register_post_type('micro', array(
	'label' => __('Micros'),
	'capability_type' => 'post',
	'hierarchical' => true

Results: (with permalinks: '/%postname%/')
www.example.com/about/ (works; since normal page)
www.example.com/micro/post-name/ (works; since complete permalink)
www.example.com/micro/ (404; not a page, not a menu item, not a permalink)

The problem is also notable at the menu manager, since it's only possible to add direct links to the posts like links to normal pages.
While a link to the slug only would/could be desirable (like blog listing).

Change History (4)

#1 @nacin
6 years ago

More or less a roundabout duplicate of #12974.

#2 follow-up: @markmcwilliams
6 years ago

Umm Nacin beat me to it, all I'm going to say on the subject is more and more people are talking about this now! Shouldn't this be marked and closed at duplicate? :D

#3 in reply to: ↑ 2 @grezvany13
6 years ago

  • Resolution set to duplicate
  • Status changed from new to closed

You're both right, it's a duplicate of #12974 (my bad).

Therefor closed.

#4 @nacin
6 years ago

  • Milestone 3.0 deleted
Note: See TracTickets for help on using tickets.