WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 3 years ago

Last modified 3 years ago

#13035 closed defect (bug) (worksforme)

Gallery Problem in two places

Reported by: mrgtb Owned by:
Milestone: Priority: high
Severity: major Version: 3.0
Component: Gallery Keywords:
Focuses: Cc:

Description

I think I've spotted some issues with the Gallery in two places.

1: Images getting cut off

Take a look at this article posted here and click the small image of the cat: http://mrgtb.com/blog/articles/personal/merlin-the-lazy-black-cat-162/

You should then be lead to this Gallery Page page where you can view a larger image of the cat, which has been (cut off) in height: http://mrgtb.com/blog/articles/personal/merlin-the-lazy-black-cat-162/attachment/image-162-1/

I'm using these size settings in my MEDIA setting below:

Small: 120x90
Medium: 280x210
Large: 560x420

As you can see from those settings, the Gallery Page should not be cutting off the image on height, seeing as the image is 640x480 is full size, and all my Media sizes are set-up to resize down from that perfectly proportionality.

2: Image for articles uploaded not showing up

Take a look at the screen-shot included to give you a better idea of what I mean. If I upload a image for an article (from within the article itself). When I click images to add, it should list how many images have been uploaded to choose from for that article. But when I click the Gallery tab it shows no images uploaded for that article, and instead I have to click the Media Library to see any images, which is not how it should be working.

Attachments (3)

pictures.zip (101.8 KB) - added by mrgtb 4 years ago.
Snap1.gif (93.5 KB) - added by mrgtb 4 years ago.
Snap2.gif (8.7 KB) - added by mrgtb 4 years ago.

Download all attachments as: .zip

Change History (7)

mrgtb4 years ago

mrgtb4 years ago

mrgtb4 years ago

comment:1 kretzschmar4 years ago

I can confirm this bug. It worked here a few commits before.

comment:2 hakre4 years ago

Is this still a problem?

comment:3 simonwheatley3 years ago

  • Resolution set to worksforme
  • Status changed from new to closed

Re sizing issues (1):

I can't reproduce this on the page (using TwentyTen theme). All the sizes called for with these media settings are also created.

An additional vertically cropped image is created as the post thumbnail... I wonder if this is the issue.

Re upload issues (2):

I can't reproduce these either.

Recommend closing ticket.

comment:4 scribu3 years ago

  • Milestone Awaiting Review deleted
Note: See TracTickets for help on using tickets.