WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#13076 closed defect (bug) (fixed)

WP Class incorrectly checks against custom taxonomy and post_type names instead of query_var

Reported by: prettyboymp Owned by:
Milestone: Priority: high
Severity: normal Version: 3.0
Component: Posts, Post Types Keywords: has-patch
Focuses: Cc:

Description

WP Class incorrectly checks against custom taxonomy and post_type names instead of query_var. This is causing sites that have a post_type and taxonomy with the same name to conflict.

Attachments (1)

13076.patch (823 bytes) - added by prettyboymp 5 years ago.

Download all attachments as: .zip

Change History (5)

@prettyboymp5 years ago

comment:1 @scribu5 years ago

  • Component changed from General to Post Types
  • Milestone changed from Unassigned to 3.0

I can confirm that I've been bitten by this bug.

comment:2 @dd325 years ago

Duplicate of #12857

comment:3 @scribu5 years ago

  • Milestone 3.0 deleted
  • Resolution set to duplicate
  • Status changed from new to closed

comment:4 @ryan5 years ago

  • Resolution changed from duplicate to fixed

(In [14246]) Fix custom tax and post type query var checks. Props prettyboymp. fixes #12857 #13076

Note: See TracTickets for help on using tickets.