WordPress.org

Make WordPress Core

Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#13102 closed defect (bug) (invalid)

Infinite Redirects Problem

Reported by: dtrimble Owned by: markjaquith
Milestone: Priority: high
Severity: blocker Version:
Component: Canonical Keywords:
Focuses: Cc:

Description

One of my sites, http://cgblog.org went live yesterday after a massive re-build from the ground up. The site was working fine all through the night, but now access to one area of the site in particular (Community/Forums from our menu bar) is generating a Too Many Redirects error, and won't come up. Some of my readers are telling me they can get to it, however, so it seems inconsistent.

A couple things to note:

  1. We used to have the site at www.cgblog.org, but for efficiency I've opted to drop the www. on the new site, and have .htaccess configured to redirect accordingly:

RewriteEngine On RewriteBase / RewriteCond %{HTTP_HOST} www.cgblog.org$ [NC] RewriteRule (.*)$ http://cgblog.org/$1 [R=301]

  1. We also used to use long-form URLs for all of our blog posts. The form of /year/month/date/post-title/. Again for efficiency, we've opted to now use just the WordPress page ID going forward. All of the old posts are still in the database, so we have years worth of people linking to the old URLs.

Is this something I'm doing wrong with our site, or is this a problem with WP's handling of canonical URLs? I haven't a clue what the problem is let alone how to fix, so I'd greatly prefer any help. A core part of our blog is down in the mean time as long as folks keep getting this pesky redirect error.

Change History (2)

#1 @scribu
8 years ago

  • Resolution set to invalid
  • Status changed from new to closed

You should ask this in the support forums.

#2 @scribu
8 years ago

  • Milestone Unassigned deleted
Note: See TracTickets for help on using tickets.