WordPress.org

Make WordPress Core

Opened 8 years ago

Closed 4 years ago

Last modified 4 years ago

#13147 closed enhancement (duplicate)

Add-menu-item boxes should slide on expand/collapse

Reported by: koopersmith Owned by:
Milestone: Priority: lowest
Severity: minor Version: 3.0
Component: Menus Keywords:
Focuses: javascript Cc:

Description

Self-descriptive. This part of a #13134 patch wasn't being cooperative, so I moved it here.

Attachments (1)

13147.1.patch (1.0 KB) - added by koopersmith 8 years ago.

Download all attachments as: .zip

Change History (13)

#1 @koopersmith
8 years ago

  • Component changed from General to Menus
  • Owner set to filosofo

#2 @koopersmith
8 years ago

  • Summary changed from Add-menu-item boxes and menu items should slide on expand/collapse to Add-menu-item boxes should slide on expand/collapse

A variant of this patch was having trouble in IE6 before. This was likely due to jQuery not standardizing a complex selector correctly. I've tweaked it a bit, so hopefully IE6 will cooperate now.

@koopersmith
8 years ago

#3 @filosofo
8 years ago

  • Owner filosofo deleted
  • Status changed from new to assigned

#4 @nacin
8 years ago

  • Keywords ux-feedback added
  • Owner set to koopersmith

We don't slide meta boxes elsewhere, but everything else in menus slide. Though, we do slide in widgets. Thinking yes to this, it's less jarring.

#5 @johnonolan
8 years ago

I'm +1 on this, additionally the dropdown arrows on the menus widgets need cursor-style:pointer added to them if you want to integrate that into the same patch?

#6 @koopersmith
8 years ago

  • Milestone changed from 3.0 to Future Release

We don't do this for meta-boxes anywhere else, including widgets. It is nice effect though and if properly implemented (and cross-browser) could be tied into the meta-box JS so we could pick up the enhancements across the admin panel. Punting to future release.

#7 @koopersmith
6 years ago

  • Milestone changed from Future Release to 3.4
  • Owner koopersmith deleted

Moving to 3.4 as something to think about if we choose to update menus. If the add-menu-item boxes remain in the meta box format, then we should consider if/how we would want to implement this across the broader admin UI.

I would be inclined against adding a sliding animation across the admin, but would be open to seeing patches — we should only animate when it helps a user maintain her bearings within the UI.

#8 @jane
6 years ago

  • Keywords ux-feedback removed

This was marked as 3.4 2 months ago but no action. Commit or punt?

#9 @ryan
6 years ago

  • Milestone changed from 3.4 to Future Release

#10 @celloexpressions
4 years ago

  • Resolution set to duplicate
  • Status changed from assigned to closed

Fixed in 3.6 by #23890, #23450.

#11 @DrewAPicture
4 years ago

  • Focuses javascript added
  • Milestone changed from Future Release to 3.6
  • Resolution changed from duplicate to fixed

#12 @DrewAPicture
4 years ago

  • Milestone 3.6 deleted
  • Resolution changed from fixed to duplicate

Duplicate of #23890.

Whoops.

Note: See TracTickets for help on using tickets.