WordPress.org

Make WordPress Core

Opened 11 years ago

Closed 11 years ago

#13171 closed defect (bug) (fixed)

Problem unpacking some plugins...

Reported by: flashingcursor Owned by: dd32
Milestone: 3.0 Priority: high
Severity: blocker Version: 3.0
Component: Upgrade/Install Keywords:
Focuses: Cc:

Description

Using the FTP method:

Installing Plugin from uploaded file: oiopub-pro-v2.26.zip
Unpacking the package…

Could not create directory. /domains/flashingcursor.com/public_html/wp-content/upgrade/oiopub-pro-v2.26/oiopub-direct/modules/2checkout

This happened with one other plugin a week or two back, but I figured it was just a bad file ... this has been tested on a 2.9 install / same environment and it works fine.

Change History (13)

#1 @dd32
11 years ago

  • Component changed from Filesystem to Upgrade/Install
  • Keywords reporter-feedback added

A few things to confirm:

  • This only happens with some plugins
  • This happens all the time with these plugins?
  • Can you provide a link to a plugin zip which suffers from the problem?

#2 @flashingcursor
11 years ago

It's a commercial plugin. I've asked the author permission to give you a copy. Waiting to hear back. (Might need your email address for that)

It does happen every time with this particular plugin.

Most plugins I've tried work fine. There has been one other occasion that caused this same error, but I cannot find the plugin archive to try to duplicate the issue. Will keep trying and update here.

#3 @nacin
11 years ago

  • Keywords close added

We're going to need some feedback on this or this ticket will be closed.

From what I'm reading, the plugin is not licensed under the GPL but it is not restricted by site. I doubt the developer/author would have a problem with loaning it to the core team without permission first. It may reveal a bug.

#4 @aldolat
11 years ago

  • Cc aldolat@… added

I have had this same problem some minutes ago. I was trying to install via backend the plugin "Maintenance Mode" [1] and got this error:
"Incompatible Archive. PCLZIP_ERR_BAD_FORMAT (-10) : Invalid archive structure".

I tried this on my online server and in localhost.

Manually unpacking the compressed file works fine, though (on Linux).

[1] http://wordpress.org/extend/plugins/maintenance-mode/

#5 @flashingcursor
11 years ago

Problematic plugin emailed to Andrew. =)

#6 @nacin
11 years ago

  • Keywords reporter-feedback close removed
  • Severity changed from normal to blocker

Plugin also forwarded to Dion.

I can confirm that this plugin installs on 2.9 and does not on trunk.

Could not create directory. C:\xampp\htdocs\commit/wp-content/upgrade/oiopub-pro-v2.26/oiopub-direct/modules/2checkout

Notice: Undefined property: Plugin_Installer_Skin::$result in C:\xampp\htdocs\commit\wp-admin\includes\class-wp-upgrader.php on line 1228

#7 @nacin
11 years ago

Having no problems with the maintenance mode plugin however.

#8 @dd32
11 years ago

That zip file is failing the Consistency checks of the PHP Zip Extension, Raising ZIPARCHIVE::ER_INCONS.

PclZip is handling that case however, as are other Zip tools.

The problem that is occuring, is that a oiopub-direct/modules/ node does not exist within the archive, however, child nodes oiopub-direct/modules/2checkout for example do exist. If there was a file within oiopub-direct/modules then even if the node didnt exist, some compat functionality inside the unzip class would work around it, As it is, as you can see, its failing.

I'll work up some kind of compat code for this case

#9 @dd32
11 years ago

ZIPARCHIVE::ER_INCONS.

That error being "Archive is Inconsistent"

#10 follow-up: @dd32
11 years ago

  • Resolution set to fixed
  • Status changed from new to closed

(In [14811]) Ensure that the entire folder structure exists within the $needed_folders array before attempting to create folders. Fixes cases where the Zip file does not contain a node for a folder which contains subfolders without files in the same level. Fixes #13171

#11 in reply to: ↑ 10 @aldolat
11 years ago

Ok, now it works: the plugin is installed successfully.

#12 @pavelevap
11 years ago

  • Cc pavelevap@… added
  • Resolution fixed deleted
  • Status changed from closed to reopened

Similar problem (latest trunk version, localhost with xampp on Windows):

Some plugins (and only some versions) end with "Could not remove the old plugin."

Example (plugin wp Time Machine):
Upgrade (yesterday) wp-time-machine from version 1.9.1 to 1.9.3 = OK.
Upgrade (today) wp-time-machine from version 1.9.3 - 1.9.4 = Upgrade failed.

The same problem appeared for me also with following plugins (in last two weeks):
mass-custom-fields-manager 1.2 - 1.3
pods 1.8.7 - 1.8.8
gd-taxonomies-tools 1.1.8 - 1.1.9
odlinks 1.1.1-a - 1.1.2-a

This strange behaviour is somehow random, some plugins are not affected, some are affected only with particular version...

#13 @dd32
11 years ago

  • Resolution set to fixed
  • Status changed from reopened to closed

pavelevap: I'm going to open a new ticket for your problems, as they're unrelated to the core problem of this ticket. I've got some followup questions there too. #13571

Note: See TracTickets for help on using tickets.