WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 3 years ago

#13192 closed defect (bug) (worksforme)

Portrait image cropped in image editor

Reported by: Radoslav Owned by: nacin
Milestone: Priority: normal
Severity: normal Version: 2.9.2
Component: Gallery Keywords: reporter-feedback
Focuses: Cc:

Description

Hi,

portrait-oriented images in my image editor are cropped (see example). This is how it should look like.

The image tested has 633x950 pixels - it's size shouldn't be a problem.

The problem appears only when I turn on the Modfolio theme from GraphPaperPress and upload a new image.

Uploading an image uder Default WP theme solves the issue.

Uploading an image under Default WP theme, then switching to Modfolio theme does not produce the issue.

Uploading an image under Modfolio and switching to Default does produce the issue.

I have went through the sticky on image editor - it didn't help.

GraphPaperPress support confirmed the issue with one difference - switching to default theme doesn't solve it for them. In their opinion this is a WP bug.

My setup:

  • Wordpress 2.9.2 with Modfolio them from GraphPaperPress
  • Firefox 3.6.6 with Flash 10 - I use add-ons, but switching to safe mode doesn't solve the problem
  • I've double checked my media settings in WP are correct for the theme

Change History (4)

comment:1 Radoslav4 years ago

Here are the correct links to illustrate the issue:
1) Image editor with a bug (under GraphPaperPress.com Modfolio theme): link
2) Image editor working correctly (under Default WP theme): link

comment:2 nacin3 years ago

  • Keywords reporter-feedback added

I'm reaching out to GraphPaperPress for a copy of the theme.

comment:3 nacin3 years ago

  • Owner set to nacin
  • Status changed from new to reviewing

comment:4 nacin3 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to worksforme
  • Status changed from reviewing to closed

I haven't had the chance to actually look at Modfolio, but Thad says the theme was updated some time ago and that this was fixed.

Note: See TracTickets for help on using tickets.