Make WordPress Core

Opened 5 years ago

Closed 5 years ago

#13219 closed defect (bug) (fixed)

"Add to Menu" adds selections from other boxes

Reported by: ryan Owned by:
Milestone: 3.0 Priority: normal
Severity: normal Version:
Component: Menus Keywords: ux-feedback
Focuses: Cc:


Select items in the Categories and Pages boxes. Press "Add to Menu" in one of the boxes. Selections from all boxes are added instead of just the box where "Add to Menu" is pressed. This could be handy when done intentionally, but it is unexpected.

Change History (6)

#1 @filosofo
5 years ago

I think this is a feature, not a bug.

Also, if this behavior is changed and is consistent with non-js users, we'll need to make the meta-boxes each act as separate forms, which would differ both from current menu meta-box behavior and the behavior of meta boxes on the post object edit pages.

#2 @nacin
5 years ago

The plan is to break these into multiple forms, especially given the multiple "Add to Menu" buttons. I believe it has been determined that it isn't desired UX behavior, nor in line with the UI, which keeps these meta boxes very distinct.

#3 @filosofo
5 years ago

  • Owner filosofo deleted
  • Status changed from new to assigned

Makes sense.

#4 @nacin
5 years ago

  • Keywords ux-feedback added

[14436] -- Have 'Add to Menu' and multiple-item drag/drop only affect one meta box at a time. props ptahdunbar, with koopersmith. Non-JS will still handle the meta boxes all together as one form. see #13220, see #13219.

Leaving open for ux-feedback due to the last part. If that is acceptable (that "Add to Menu" in non-JS will add for all), then let's close as fixed.

#5 @johnonolan
5 years ago

I think it's an acceptable quirk, it doesn't render the interface unusable by any means.

#6 @ryan
5 years ago

  • Resolution set to fixed
  • Status changed from assigned to closed
Note: See TracTickets for help on using tickets.