WordPress.org

Make WordPress Core

Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#13259 closed defect (bug) (fixed)

On ms-sites.php the Backend link directs to the main site backend

Reported by: selad Owned by:
Milestone: 3.0 Priority: normal
Severity: normal Version:
Component: General Keywords: reporter-feedback
Focuses: Cc:

Description

Using trunk, on ms-sites.php the Backend link directs to the main site backend and not the specific blogs.

using sub-directories and all sites created by the site admin.

Change History (12)

#1 follow-up: @ocean90
8 years ago

Does it happen on my-sites.php too? Is it a local install with XAMPP?

#2 in reply to: ↑ 1 @ocean90
8 years ago

  • Keywords reporter-feedback added

Replying to ocean90:

Does it happen on my-sites.php too? Is it a local install with XAMPP?

For some weeks it was a problem on my local install, but not anymore. Can you give some more details? Server config? Is the URL on hover right and it redirect false?

#3 @ousep
8 years ago

  • Cc ousep added

Confirming same bug as reported, but with subdomains instead of folders. All the sites were created by the super-admin. The network is being hosted online, not locally. The URL on hover points to the main site's backend, and clicks through accordingly. Server config? Ummm... https://www.nearlyfreespeech.net/

#4 @ocean90
8 years ago

  • Milestone changed from Unassigned to 3.0

Set 3.0 for reviewing. Please give us as much details as possible.

#5 @ryan
8 years ago

  • Resolution set to fixed
  • Status changed from new to closed

There have been fixes for this recently. ousep, can you use the latest nightly build and confirm whether this is fixed for you?

Since no one else can reproduce this using latest svn, closing as fixed. Feel free to re-open with more information.

#6 @ousep
8 years ago

  • Resolution fixed deleted
  • Status changed from closed to reopened

Have tried it out again, with the latest svn (r14938)... created a new site using the super-admin account. The same issue persists.

This isn't a problem in my-sites.php, where all links work as expected.

Promoted another user to super-admin, and they see everything as it should be. This bug exists only for the original super-admin .

#7 @gluten
8 years ago

I was having this same problem with a subdomain configuration of trunk (3.0-beta2-14896). The links started working again when I disabled the "WordPress MU Domain Mapping" plugin.

#9 @ryan
8 years ago

Related changesets: [14702] [14429]

#10 @donncha
8 years ago

Can you try the development version of domain mapping? That has a number of fixes for 3.0.

#11 @nacin
8 years ago

  • Resolution set to fixed
  • Status changed from reopened to closed

Please re-open if you are not running the domain mapping plugin and you still experience this issue.

#12 @ousep
8 years ago

Ah... domain mapping is the cause. Sorry for the runaround.

Note: See TracTickets for help on using tickets.