WordPress.org

Make WordPress Core

Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#13296 closed enhancement (duplicate)

Plugin queue to match scripts and styles

Reported by: johnjamesjacoby Owned by: westi
Milestone: Priority: normal
Severity: minor Version:
Component: Plugins Keywords: has-patch
Focuses: Cc:

Description

An issue arises with BuddyPress, where it's impossible to easily control plugin dependency from within BuddyPress.

If plugins had a way to tell WordPress which other plugins they depend on being active, this would help tremendously.

Most of this patch is code taken straight out of existing functions.wp-scripts.php and class.wp-scripts.php.

This patch doesn't integrate directly into the WP plugin architecture yet. The plugin code has remained mostly untouched for a while and I didn't want to be the guy that broke it (yet) :)

Attachments (1)

plugin-queue-idea.patch (6.7 KB) - added by johnjamesjacoby 8 years ago.

Download all attachments as: .zip

Change History (4)

#1 @nacin
8 years ago

Duplicate of #11308?

#2 @johnjamesjacoby
8 years ago

  • Resolution set to duplicate
  • Status changed from new to closed

#3 @nacin
8 years ago

  • Milestone 3.1 deleted
Note: See TracTickets for help on using tickets.