WordPress.org

Make WordPress Core

Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#13369 closed defect (bug) (fixed)

wp-signup.php does not validate when user logged in.

Reported by: snumb130 Owned by: nacin
Milestone: 3.0 Priority: normal
Severity: minor Version: 3.0
Component: Validation Keywords: has-patch
Focuses: Cc:

Description

When user logged in the wp-signup.php page shows the following errors when validating against HTML5.

Line 66: No p element in scope but a p end tag seen.

  • caused by lines 179 through 187 of wp-signup.php. ul is nexted within p. Move closing p before the linked list.

Line 72: No p element in scope but a p end tag seen.

  • caused by line 98 where closing p is given with no opening p. Remove closing p tag.

Line 85: No p element in scope but a p end tag seen.

  • caused by lines 102 through 114 of wp-signup.php. div is nested in p. Close p before div and open afterward.

Attachments (2)

wp-signup.php.diff (1.9 KB) - added by snumb130 8 years ago.
Patch to wp-signup.php to fix html5 validation errors when user logged in.
13369.patch (1.7 KB) - added by ocean90 8 years ago.
use br instead of div.

Download all attachments as: .zip

Change History (6)

@snumb130
8 years ago

Patch to wp-signup.php to fix html5 validation errors when user logged in.

@ocean90
8 years ago

use br instead of div.

#1 @ocean90
8 years ago

  • Component changed from General to Validation
  • Keywords has-patch added; validation html5 multisite removed
  • Milestone set to 3.0
  • Owner set to nacin
  • Status changed from new to reviewing
  • Type changed from enhancement to defect (bug)

#2 @nacin
8 years ago

  • Resolution set to fixed
  • Status changed from reviewing to closed

(In [15199]) Valid HTML for wp-signup. fixes #13369, props ocean90, snumb130.

#3 @nacin
8 years ago

(In [15201]) Provide context for screen options plural labels. fixes #13369.

#4 @nacin
8 years ago

Part of [15199] was reverted in [15200], then committed in [15201], which was actually for #13673. I need a vacation.

Note: See TracTickets for help on using tickets.