WordPress.org

Make WordPress Core

Opened 9 years ago

Closed 9 years ago

Last modified 4 years ago

#13375 closed defect (bug) (duplicate)

Make admin styles more re-usable

Reported by: aaroncampbell Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.0
Component: UI Keywords: needs-patch gsoc
Focuses: Cc:
PR Number:

Description

I had a project recently where I wanted to create a meta box that worked very much like the Custom Fields box. I also wanted to style it similarly. Unfortunately, to style it like the custom fields box you need your content wrapped in a div with the id postcustomstuff and have that wrapped in a div with the id postcustom. Luckily for me, I was creating this to be used with the Shopp plugin, so those IDs are not already in use.

However, if you wanted to do the same thing and it needed to work in conjunction with the custom fields box, there'd be no way to re-use those styles. Actually, there'd be no good way to style it properly at all. When I looked into it, I'd have to copy styles from the admin css, the rtl css, and even from colors-clasic and colors-fresh. Even then, I could only style it for those two admin themes and not any admin theme.

It seems that there are a LOT of these cases in the admin styles. If it's something a user might want to duplicate (any meta boxes for example), it should use classes so it can be duplicated. Maybe even name the classes more generically so they don't have to do with "postcustom".

Change History (5)

#1 @wojtek.szkutnik
9 years ago

  • Keywords gsoc added

#2 @TECannon
9 years ago

Related: #14770

#3 @aaroncampbell
9 years ago

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #14770

#4 @nacin
9 years ago

  • Milestone Awaiting Triage deleted

#5 @chriscct7
4 years ago

#23575 was marked as a duplicate.

Note: See TracTickets for help on using tickets.