WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 3 years ago

#13402 closed defect (bug) (worksforme)

wp_list_comments destroys $post for a paged comment

Reported by: tetonbabe Owned by:
Milestone: Priority: normal
Severity: normal Version: 2.9.2
Component: General Keywords: reporter-feedback
Focuses: Cc:

Description

If a page has a comment and I call:
echo 'before post = ' . $post->ID;
wp_list_comments(...);
echo 'after post = ' . $post->ID;

The ID appears as 2 before the call to wp_list_comments, and as the empty string after the call.

This can be duplicated in the Atahualpa Theme 3.4.6, by editing comments.php as described above for the 3rd (and last) call to wp_list_comments, and configuring Atahualpa Theme Options -> Style and Configure Comments -> Allow comments on pages. Then add a comment to the About page.

Change History (4)

comment:1 tetonbabe4 years ago

  • Cc tetonbabe added

comment:2 nacin3 years ago

  • Milestone changed from Awaiting Review to 3.1

comment:3 blepoxp3 years ago

  • Keywords reporter-feedback added

I could not reproduce this using the TwentyTen theme. Could you please use the TwentyTen theme and tell me if you can reproduce. There's a good chance this is the theme's fault.

comment:4 ryan3 years ago

  • Milestone 3.1 deleted
  • Resolution set to worksforme
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.