Make WordPress Core

Opened 5 years ago

Closed 5 years ago

#13406 closed defect (bug) (wontfix)

$current_site global consistency problem

Reported by: hakre Owned by:
Milestone: Priority: lowest
Severity: normal Version: 3.0
Component: Multisite Keywords: has-patch dev-feedback
Focuses: Cc:


While beta-testing I ran over this and I ask myself if this was intended by design:

ms-settings.php #51:
$current_site = wpmu_current_site();

ms-load.php #110ff:

function wpmu_current_site() {
	global $wpdb, $current_site, $domain, $path, $sites, $cookie_domain;
   		return $current_site;

I've attached a patch.

Attachments (1)

13406.patch (656 bytes) - added by hakre 5 years ago.

Download all attachments as: .zip

Change History (2)

@hakre5 years ago

comment:1 @nacin5 years ago

  • Milestone 3.0 deleted
  • Resolution set to wontfix
  • Status changed from new to closed

<rboren> It is a bit strange to assign it twice, although I think the current way makes ms-settings.php more readable.

I agree with this.

Note: See TracTickets for help on using tickets.