WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 4 years ago

#13410 closed defect (bug) (fixed)

Wordpress 3.0 beta 2 and php 4.4

Reported by: pivari Owned by: markjaquith
Milestone: 3.0 Priority: high
Severity: normal Version: 3.0
Component: Canonical Keywords: php4-compat
Focuses: Cc:

Description

I've installed wordpress 3.0 beta 2 and I've this problem
Warning: in_array() [function.in-array]: Wrong datatype for first argument in /usr/local/share/doc/vhost/pivari.com/httpdocs/wp-includes/canonical.php on line 180

We discussed the problem in the forum
http://wordpress.org/support/topic/397686
and we think the problem is for php 4.
I've php 4.4

Fabrizio

Change History (5)

comment:1 westi4 years ago

  • Cc dd32 markjaquith added
  • Component changed from General to Canonical
  • Keywords needs-patch php4-compat added
  • Owner set to markjaquith
  • Priority changed from normal to high

Thanks for reporting this.

I think this may be that in PHP4 in_array() does not support having an Object as the $needle.

We need to look for a fix for this.

Introduce in [13781] for #11907

comment:2 nacin4 years ago

That is correct, PHP4 does not handle objects as needles for in_array.

comment:3 westi4 years ago

(In [14696]) Switch to checking on tt_ids for the category lookup to ensure in_array call is PHP4 compatible. See #13410

comment:4 westi4 years ago

  • Keywords needs-patch removed

That should hopefully make this code PHP4 compatible.

Please test with the next nightly build (3.0-beta2-14697) and report back :-)

comment:5 ryan4 years ago

  • Resolution set to fixed
  • Status changed from new to closed

Feedback on the forum thread confirms fixed.

Note: See TracTickets for help on using tickets.